GCC and Solaris 2.7

Kennedy, Robert (SAIC) robert.kennedy@sed.redstone.army.mil
Mon Jan 24 11:46:00 GMT 2000


Hello, 

We recently upgraded from Solaris 2.5.1 to Solaris 2.7.  We had been using
gcc version 2.7 with no problems. After the upgrade, we have started getting
errors saying that there were "conflicting types for built-in function" for
memcpy, memcmp, and memset.   These errors got produced when we tried to
compile anything with the gcc after we upgraded the OS. 

When I contacted the vendor that makes the tool that was trying to use the
gcc compiler they said that I needed to get a newer version of the compiler
and install it and that it should resolve the problem. So, I downloaded
version 2.95.1 of gcc and have been trying to install it.  When I tried the
"make bootstrap", it fails, producing errors that say that there are
conflicting types for these same 3 built-in functions.  The error is
pointing to /usr/local/include/string.h.  When I look at that file, it's got
"extern" declarations for these functions.  I've tried removing this file.
When I do that, I don't get the error messages about those functions during
the make bootstrap.  Instead I get a whole list of warnings about different
items being "redefined" and it being the "location of the previous
definition".  After all of those go by, I get a message saying that all of
the following are undefined symbols:  stdout, __fillbf, __flshfp,
__ctype_toupper, __ctype_b, stdin, and stderr.  These are a fatal error for
ld, so it bails out.

Any help in resolving these errors would be greatly appreciated.

Robert E Kennedy III
Software Engineer
Science Applications International Corporation
6725 Odyssey Drive, Huntsville AL 35806-3301
Phone (256) 876-5842  Fax (256) 876-5699
Email: robert.e.kennedy.iii@cpmx.saic.com



More information about the Gcc-help mailing list