[gcc r14-8009] gccrs: Rename "rust_error_codes.def" to "rust-error-codes.def"
Arthur Cohen
cohenarthur@gcc.gnu.org
Tue Jan 16 18:13:09 GMT 2024
https://gcc.gnu.org/g:b1b42beea3d16d9b129ee53d173a299c5c8d33e2
commit r14-8009-gb1b42beea3d16d9b129ee53d173a299c5c8d33e2
Author: Owen Avery <powerboat9.gamer@gmail.com>
Date: Wed Sep 13 00:36:06 2023 -0400
gccrs: Rename "rust_error_codes.def" to "rust-error-codes.def"
gcc/rust/ChangeLog:
* rust_error_codes.def: Moved to...
* rust-error-codes.def: ...here...
* rust-diagnostics.h: ...and update references.
Signed-off-by: Owen Avery <powerboat9.gamer@gmail.com>
Diff:
---
gcc/rust/rust-diagnostics.h | 4 ++--
gcc/rust/{rust_error_codes.def => rust-error-codes.def} | 0
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/gcc/rust/rust-diagnostics.h b/gcc/rust/rust-diagnostics.h
index 1ae4a292e77..3da1881bb6c 100644
--- a/gcc/rust/rust-diagnostics.h
+++ b/gcc/rust/rust-diagnostics.h
@@ -59,7 +59,7 @@
// We want E0005 to be mapped to the value `5` - this way, we can easily format
// it in `make_description`. We also want to keep the value "5" only once when
-// defining the error code in rust_error_codes.def, so not have ERROR(E0005, 5)
+// defining the error code in rust-error-codes.def, so not have ERROR(E0005, 5)
// as that is error prone. If we just use `0005` as the discriminant for the
// `E0005` enum variant, then we are actually creating octal values (!) as `0`
// is the C/C++ octal prefix. So this does not work for `E0009` for example,
@@ -75,7 +75,7 @@
#define ERROR(N) E##N = (1##N - 10000)
enum class ErrorCode : unsigned int
{
-#include "rust_error_codes.def"
+#include "rust-error-codes.def"
};
#undef ERROR
diff --git a/gcc/rust/rust_error_codes.def b/gcc/rust/rust-error-codes.def
similarity index 100%
rename from gcc/rust/rust_error_codes.def
rename to gcc/rust/rust-error-codes.def
More information about the Gcc-cvs
mailing list