[gcc r14-6405] RISC-V: Rename test[NFC]
Lehua Ding
lhtin@gcc.gnu.org
Mon Dec 11 09:58:53 GMT 2023
https://gcc.gnu.org/g:63194a0e8ede9e15dfa01c6ec7aeea8f7702d3b7
commit r14-6405-g63194a0e8ede9e15dfa01c6ec7aeea8f7702d3b7
Author: Juzhe-Zhong <juzhe.zhong@rivai.ai>
Date: Mon Dec 11 17:44:24 2023 +0800
RISC-V: Rename test[NFC]
Since I want to commit multiple tests which are fixing vsetvl bugs,
rename it to make testcases more easier maintain.
Committed as it is obvious.
gcc/testsuite/ChangeLog:
* gcc.target/riscv/rvv/vsetvl/avl_use_bug-1.c: Moved to...
* gcc.target/riscv/rvv/vsetvl/vsetvl_bug-1.c: ...here.
Diff:
---
.../gcc.target/riscv/rvv/vsetvl/{avl_use_bug-1.c => vsetvl_bug-1.c} | 2 ++
1 file changed, 2 insertions(+)
diff --git a/gcc/testsuite/gcc.target/riscv/rvv/vsetvl/avl_use_bug-1.c b/gcc/testsuite/gcc.target/riscv/rvv/vsetvl/vsetvl_bug-1.c
similarity index 99%
rename from gcc/testsuite/gcc.target/riscv/rvv/vsetvl/avl_use_bug-1.c
rename to gcc/testsuite/gcc.target/riscv/rvv/vsetvl/vsetvl_bug-1.c
index 330221c2d7b..45727a035b4 100644
--- a/gcc/testsuite/gcc.target/riscv/rvv/vsetvl/avl_use_bug-1.c
+++ b/gcc/testsuite/gcc.target/riscv/rvv/vsetvl/vsetvl_bug-1.c
@@ -6,10 +6,12 @@ struct a_struct
unsigned char a_character;
};
+
struct a_struct an_array[5];
struct a_struct *a_ptr;
int yabba = 1;
+
int
f (a, b)
unsigned char a;
More information about the Gcc-cvs
mailing list