[gcc r12-3907] Daily bump.

GCC Administrator gccadmin@gcc.gnu.org
Tue Sep 28 00:16:51 GMT 2021


https://gcc.gnu.org/g:cf966403d91afcf475347f0d06dd2b7215ae3611

commit r12-3907-gcf966403d91afcf475347f0d06dd2b7215ae3611
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Tue Sep 28 00:16:21 2021 +0000

    Daily bump.

Diff:
---
 gcc/ChangeLog           | 136 ++++++++++++++++++++++++++++++++++++++++++++++++
 gcc/DATESTAMP           |   2 +-
 gcc/c-family/ChangeLog  |   5 ++
 gcc/cp/ChangeLog        |   8 +++
 gcc/fortran/ChangeLog   |  19 +++++++
 gcc/go/ChangeLog        |   5 ++
 gcc/lto/ChangeLog       |   5 ++
 gcc/testsuite/ChangeLog |  67 ++++++++++++++++++++++++
 include/ChangeLog       |   4 ++
 libgfortran/ChangeLog   |   6 +++
 libgomp/ChangeLog       |  17 ++++++
 11 files changed, 273 insertions(+), 1 deletion(-)

diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index e8bef28cc27..218c10abe78 100644
--- a/gcc/ChangeLog
+++ b/gcc/ChangeLog
@@ -1,3 +1,139 @@
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* gimple-range-path.cc
+	(path_range_query::precompute_ranges_in_block): Rename to...
+	(path_range_query::compute_ranges_in_block): ...this.
+	(path_range_query::precompute_ranges): Rename to...
+	(path_range_query::compute_ranges): ...this.
+	(path_range_query::precompute_relations): Rename to...
+	(path_range_query::compute_relations): ...this.
+	(path_range_query::precompute_phi_relations): Rename to...
+	(path_range_query::compute_phi_relations): ...this.
+	* gimple-range-path.h: Rename precompute* to compute*.
+	* tree-ssa-threadbackward.c
+	(back_threader::find_taken_edge_switch): Same.
+	(back_threader::find_taken_edge_cond): Same.
+	* tree-ssa-threadedge.c
+	(hybrid_jt_simplifier::compute_ranges_from_state): Same.
+	(hybrid_jt_state::register_equivs_stmt): Inline...
+	* tree-ssa-threadedge.h: ...here.
+
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* tree-vrp.c (lhs_of_dominating_assert): Remove.
+	(class vrp_jt_state): Remove.
+	(class vrp_jt_simplifier): Remove.
+	(vrp_jt_simplifier::simplify): Remove.
+	(class vrp_jump_threader): Remove.
+	(vrp_jump_threader::vrp_jump_threader): Remove.
+	(vrp_jump_threader::~vrp_jump_threader): Remove.
+	(vrp_jump_threader::before_dom_children): Remove.
+	(vrp_jump_threader::after_dom_children): Remove.
+
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* passes.def (pass_vrp_threader): New.
+	* tree-pass.h (make_pass_vrp_threader): Add make_pass_vrp_threader.
+	* tree-ssa-threadedge.c (hybrid_jt_state::register_equivs_stmt): New.
+	(hybrid_jt_simplifier::hybrid_jt_simplifier): New.
+	(hybrid_jt_simplifier::simplify): New.
+	(hybrid_jt_simplifier::compute_ranges_from_state): New.
+	* tree-ssa-threadedge.h (class hybrid_jt_state): New.
+	(class hybrid_jt_simplifier): New.
+	* tree-vrp.c (execute_vrp): Remove ASSERT_EXPR based jump
+	threader.
+	(class hybrid_threader): New.
+	(hybrid_threader::hybrid_threader): New.
+	(hybrid_threader::~hybrid_threader): New.
+	(hybrid_threader::before_dom_children): New.
+	(hybrid_threader::after_dom_children): New.
+	(execute_vrp_threader): New.
+	(class pass_vrp_threader): New.
+	(make_pass_vrp_threader): New.
+
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* output.h (enum section_flag): New.
+	(SECTION_FORGET): Remove.
+	(SECTION_ENTSIZE): Make it (1UL << 8) - 1.
+	(SECTION_STYLE_MASK): Define it based on other enum
+	values.
+	* varasm.c (switch_to_section): Remove unused handling of
+	SECTION_FORGET.
+
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* common.opt: Add new variable flag_default_complex_method.
+	* opts.c (finish_options): Handle flags related to
+	  x_flag_complex_method.
+	* toplev.c (process_options): Remove option handling related
+	to flag_complex_method.
+
+2021-09-27  Richard Biener  <rguenther@suse.de>
+
+	PR middle-end/102450
+	* gimple-fold.c (gimple_fold_builtin_memory_op): Avoid using
+	type_for_size, instead use int_mode_for_size.
+
+2021-09-27  Andrew Pinski  <apinski@marvell.com>
+
+	PR c/94726
+	* gimplify.c (gimplify_save_expr): Return early
+	if the type of val is error_mark_node.
+
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* tree-ssanames.c (ssa_name_has_boolean_range): Use
+	get_range_query.
+
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* gimple-ssa-evrp-analyze.h (class evrp_range_analyzer): Remove
+	vrp_visit_cond_stmt.
+	* tree-ssa-dom.c (cprop_operand): Convert to range_query API.
+	(cprop_into_stmt): Same.
+	(dom_opt_dom_walker::optimize_stmt): Same.
+
+2021-09-27  Richard Biener  <rguenther@suse.de>
+
+	PR tree-optimization/97351
+	PR tree-optimization/97352
+	PR tree-optimization/82426
+	* tree-vectorizer.h (dr_misalignment): Add vector type
+	argument.
+	(aligned_access_p): Likewise.
+	(known_alignment_for_access_p): Likewise.
+	(vect_supportable_dr_alignment): Likewise.
+	(vect_known_alignment_in_bytes): Likewise.  Refactor.
+	(DR_MISALIGNMENT): Remove.
+	(vect_update_shared_vectype): Likewise.
+	* tree-vect-data-refs.c (dr_misalignment): Refactor, handle
+	a vector type with larger alignment requirement and apply
+	the negative step adjustment here.
+	(vect_calculate_target_alignment): Remove.
+	(vect_compute_data_ref_alignment): Get explicit vector type
+	argument, do not apply a negative step alignment adjustment
+	here.
+	(vect_slp_analyze_node_alignment): Re-analyze alignment
+	when we re-visit the DR with a bigger desired alignment but
+	keep more precise results from smaller alignments.
+	* tree-vect-slp.c (vect_update_shared_vectype): Remove.
+	(vect_slp_analyze_node_operations_1): Do not update the
+	shared vector type on stmts.
+	* tree-vect-stmts.c (vect_analyze_stmt): Push/pop the
+	vector type of an SLP node to the representative stmt-info.
+	(vect_transform_stmt): Likewise.
+
+2021-09-27  liuhongt  <hongtao.liu@intel.com>
+
+	Revert:
+	2021-09-09  liuhongt  <hongtao.liu@intel.com>
+
+	PR target/101059
+	* config/i386/sse.md (reduc_plus_scal_<mode>): Split to ..
+	(reduc_plus_scal_v4sf): .. this, New define_expand.
+	(reduc_plus_scal_v2df): .. and this, New define_expand.
+
 2021-09-26  liuhongt  <hongtao.liu@intel.com>
 
 	* doc/extend.texi (Half-Precision): Remove storage only
diff --git a/gcc/DATESTAMP b/gcc/DATESTAMP
index af3eb99c8f9..fbdb92926d0 100644
--- a/gcc/DATESTAMP
+++ b/gcc/DATESTAMP
@@ -1 +1 @@
-20210927
+20210928
diff --git a/gcc/c-family/ChangeLog b/gcc/c-family/ChangeLog
index 48bcb4f7df1..cf6a309ced0 100644
--- a/gcc/c-family/ChangeLog
+++ b/gcc/c-family/ChangeLog
@@ -1,3 +1,8 @@
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* c-opts.c (c_common_init_options_struct): Set also
+	  x_flag_default_complex_method.
+
 2021-09-22  Jakub Jelinek  <jakub@redhat.com>
 
 	* c-omp.c (c_omp_split_clauses): Copy over OMP_CLAUSE_ALLOCATE_ALIGN.
diff --git a/gcc/cp/ChangeLog b/gcc/cp/ChangeLog
index 6918bf9c041..f60587a905d 100644
--- a/gcc/cp/ChangeLog
+++ b/gcc/cp/ChangeLog
@@ -1,3 +1,11 @@
+2021-09-27  Patrick Palka  <ppalka@redhat.com>
+
+	PR c++/102479
+	* pt.c (rewrite_template_parm): Handle single-level tsubst_args.
+	Avoid a tree cycle when assigning the DECL_TEMPLATE_PARMS for a
+	rewritten ttp.
+	(alias_ctad_tweaks): Set current_template_parms accordingly.
+
 2021-09-23  Michel Morin  <mimomorin@gmail.com>
 
 	* parser.c (cp_keyword_starts_decl_specifier_p): Do not
diff --git a/gcc/fortran/ChangeLog b/gcc/fortran/ChangeLog
index cd13bc56382..724f3ff0194 100644
--- a/gcc/fortran/ChangeLog
+++ b/gcc/fortran/ChangeLog
@@ -1,3 +1,22 @@
+2021-09-27  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/94070
+	* trans-array.c (gfc_tree_array_size): New function to
+	find size inline (whole array or one dimension).
+	(array_parameter_size): Use it, take stmt_block as arg.
+	(gfc_conv_array_parameter): Update call.
+	* trans-array.h (gfc_tree_array_size): Add prototype.
+	* trans-decl.c (gfor_fndecl_size0, gfor_fndecl_size1): Remove
+	these global vars.
+	(gfc_build_intrinsic_function_decls): Remove their initialization.
+	* trans-expr.c (gfc_conv_procedure_call): Update
+	bounds of pointer/allocatable actual args to nonallocatable/nonpointer
+	dummies to be one based.
+	* trans-intrinsic.c (gfc_conv_intrinsic_shape): Fix case for
+	assumed rank with allocatable/pointer dummy.
+	(gfc_conv_intrinsic_size): Update to use inline function.
+	* trans.h (gfor_fndecl_size0, gfor_fndecl_size1): Remove var decl.
+
 2021-09-26  Tobias Burnus  <tobias@codesourcery.com>
 
 	PR fortran/101334
diff --git a/gcc/go/ChangeLog b/gcc/go/ChangeLog
index 60ebb892d92..c17e3a46b29 100644
--- a/gcc/go/ChangeLog
+++ b/gcc/go/ChangeLog
@@ -1,3 +1,8 @@
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* go-lang.c (go_langhook_init_options_struct): Set also
+	  x_flag_default_complex_method.
+
 2021-06-29  Ian Lance Taylor  <iant@golang.org>
 
 	* go-gcc.cc (Gcc_backend::static_chain_variable): Set
diff --git a/gcc/lto/ChangeLog b/gcc/lto/ChangeLog
index 0a2d2d1c414..1aea3f80713 100644
--- a/gcc/lto/ChangeLog
+++ b/gcc/lto/ChangeLog
@@ -1,3 +1,8 @@
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* lto-lang.c (lto_init_options_struct): Set also
+	  x_flag_default_complex_method.
+
 2021-09-03  Jakub Jelinek  <jakub@redhat.com>
 
 	PR target/102024
diff --git a/gcc/testsuite/ChangeLog b/gcc/testsuite/ChangeLog
index 8adc398e6aa..929ff612109 100644
--- a/gcc/testsuite/ChangeLog
+++ b/gcc/testsuite/ChangeLog
@@ -1,3 +1,70 @@
+2021-09-27  Patrick Palka  <ppalka@redhat.com>
+
+	PR c++/102479
+	* g++.dg/cpp1z/class-deduction12.C: Also test alias CTAD in the
+	same way.
+	* g++.dg/cpp1z/class-deduction99.C: New test.
+
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* gcc.dg/torture/pr55107.c: Adjust.
+	* gcc.dg/tree-ssa/phi_on_compare-1.c: Adjust.
+	* gcc.dg/tree-ssa/phi_on_compare-2.c: Adjust.
+	* gcc.dg/tree-ssa/phi_on_compare-3.c: Adjust.
+	* gcc.dg/tree-ssa/phi_on_compare-4.c: Adjust.
+	* gcc.dg/tree-ssa/pr21559.c: Adjust.
+	* gcc.dg/tree-ssa/pr59597.c: Adjust.
+	* gcc.dg/tree-ssa/pr61839_1.c: Adjust.
+	* gcc.dg/tree-ssa/pr61839_3.c: Adjust.
+	* gcc.dg/tree-ssa/pr71437.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-dom-thread-11.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-dom-thread-16.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-dom-thread-18.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-dom-thread-2a.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-dom-thread-4.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-thread-14.c: Adjust.
+	* gcc.dg/tree-ssa/ssa-vrp-thread-1.c: Adjust.
+	* gcc.dg/tree-ssa/vrp106.c: Adjust.
+	* gcc.dg/tree-ssa/vrp55.c: Adjust.
+
+2021-09-27  Martin Liska  <mliska@suse.cz>
+
+	* gcc.c-torture/compile/attr-complex-method-2.c: New test.
+	* gcc.c-torture/compile/attr-complex-method.c: New test.
+
+2021-09-27  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/94070
+	* gfortran.dg/c-interop/cf-out-descriptor-6.f90: Remove xfail.
+	* gfortran.dg/c-interop/size.f90: Remove xfail.
+	* gfortran.dg/intrinsic_size_3.f90: Update scan-tree-dump-times.
+	* gfortran.dg/transpose_optimization_2.f90: Likewise.
+	* gfortran.dg/size_optional_dim_1.f90: Add scan-tree-dump-not.
+	* gfortran.dg/assumed_rank_22.f90: New test.
+	* gfortran.dg/assumed_rank_22_aux.c: New test.
+
+2021-09-27  Andrew Pinski  <apinski@marvell.com>
+
+	PR c/94726
+	* gcc.dg/pr94726.c: New test.
+
+2021-09-27  Richard Biener  <rguenther@suse.de>
+
+	PR tree-optimization/97351
+	PR tree-optimization/97352
+	PR tree-optimization/82426
+	* gcc.target/i386/vect-pr82426.c: New testcase.
+	* gcc.target/i386/vect-pr97352.c: Likewise.
+
+2021-09-27  liuhongt  <hongtao.liu@intel.com>
+
+	Revert:
+	2021-09-27  liuhongt  <hongtao.liu@intel.com>
+
+	PR target/101059
+	* gcc.target/i386/sse2-pr101059.c: New test.
+	* gcc.target/i386/sse3-pr101059.c: New test.
+
 2021-09-26  Tobias Burnus  <tobias@codesourcery.com>
 
 	PR fortran/101334
diff --git a/include/ChangeLog b/include/ChangeLog
index d43a997d690..9a639c056dc 100644
--- a/include/ChangeLog
+++ b/include/ChangeLog
@@ -1,3 +1,7 @@
+2021-09-27  Vincent Lefevre  <vincent@vinc17.net>
+
+	* floatformat.h: Update pathname for IBM long double description.
+
 2021-09-22  Alan Modra  <amodra@gmail.com>
 
 	* obstack.h (__PTR_ALIGN): Expand and simplify __BPTR_ALIGN
diff --git a/libgfortran/ChangeLog b/libgfortran/ChangeLog
index 4af8e7e2766..12816cc8378 100644
--- a/libgfortran/ChangeLog
+++ b/libgfortran/ChangeLog
@@ -1,3 +1,9 @@
+2021-09-27  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/94070
+	* intrinsics/size.c (size0, size1): Comment that now not
+	used by newer compiler code.
+
 2021-09-26  Tobias Burnus  <tobias@codesourcery.com>
 
 	PR fortran/101334
diff --git a/libgomp/ChangeLog b/libgomp/ChangeLog
index e1c9f72d86b..32514745a44 100644
--- a/libgomp/ChangeLog
+++ b/libgomp/ChangeLog
@@ -1,3 +1,20 @@
+2021-09-27  Aldy Hernandez  <aldyh@redhat.com>
+
+	* team.c: Initialize start_data.
+	* testsuite/libgomp.graphite/force-parallel-4.c: Adjust.
+	* testsuite/libgomp.graphite/force-parallel-8.c: Adjust.
+
+2021-09-27  Tobias Burnus  <tobias@codesourcery.com>
+
+	* testsuite/libgomp.oacc-fortran/privatized-ref-2.f90: Change
+	dg-message back to dg-note.
+
+2021-09-27  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/94070
+	* testsuite/libgomp.oacc-fortran/privatized-ref-2.f90: Update
+	expected dg-note output.
+
 2021-09-22  Tobias Burnus  <tobias@codesourcery.com>
 
 	PR fortran/55534


More information about the Gcc-cvs mailing list