[gcc r11-7232] Daily bump.

GCC Administrator gccadmin@gcc.gnu.org
Sat Feb 13 00:17:11 GMT 2021


https://gcc.gnu.org/g:fab095dad5e1970ceae598ec9c98b07cce3eb599

commit r11-7232-gfab095dad5e1970ceae598ec9c98b07cce3eb599
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Sat Feb 13 00:16:38 2021 +0000

    Daily bump.

Diff:
---
 gcc/ChangeLog           | 51 +++++++++++++++++++++++++++
 gcc/DATESTAMP           |  2 +-
 gcc/ada/ChangeLog       |  4 +++
 gcc/analyzer/ChangeLog  | 27 +++++++++++++++
 gcc/c-family/ChangeLog  |  6 ++++
 gcc/cp/ChangeLog        | 63 ++++++++++++++++++++++++++++++++++
 gcc/fortran/ChangeLog   |  6 ++++
 gcc/testsuite/ChangeLog | 59 ++++++++++++++++++++++++++++++++
 libbacktrace/ChangeLog  |  6 ++++
 libgfortran/ChangeLog   |  6 ++++
 libstdc++-v3/ChangeLog  | 91 +++++++++++++++++++++++++++++++++++++++++++++++++
 11 files changed, 320 insertions(+), 1 deletion(-)

diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index ddf4c7f92d7..ad85986fe3b 100644
--- a/gcc/ChangeLog
+++ b/gcc/ChangeLog
@@ -1,3 +1,54 @@
+2021-02-12  Martin Sebor  <msebor@redhat.com>
+
+	* tree-pretty-print.c (print_generic_expr_to_str): Update comment.
+
+2021-02-12  Richard Sandiford  <richard.sandiford@arm.com>
+
+	* rtl-ssa/accesses.cc (function_info::make_use_available): Use
+	m_temp_obstack rather than m_obstack to allocate the temporary use.
+
+2021-02-12  Richard Sandiford  <richard.sandiford@arm.com>
+
+	* df-problems.c (df_lr_bb_local_compute): Treat partial definitions
+	as read-modify operations.
+
+2021-02-12  Richard Biener  <rguenther@suse.de>
+
+	PR middle-end/38474
+	* ipa-fnsummary.c (unmodified_parm_1): Only walk when
+	fbi->aa_walk_budget is bigger than zero.  Update
+	fbi->aa_walk_budget.
+	(param_change_prob): Likewise.
+	* ipa-prop.c (detect_type_change_from_memory_writes):
+	Properly account walk_aliased_vdefs.
+	(parm_preserved_before_stmt_p): Canonicalize updates.
+	(parm_ref_data_preserved_p): Likewise.
+	(parm_ref_data_pass_through_p): Likewise.
+	(determine_known_aggregate_parts): Account own alias queries.
+
+2021-02-12  Martin Liska  <mliska@suse.cz>
+
+	* opts-common.c (decode_cmdline_option): Release werror_arg.
+	* opts.c (gen_producer_string): Release output of
+	gen_command_line_string.
+
+2021-02-12  Richard Biener  <rguenther@suse.de>
+
+	PR tree-optimization/38474
+	* params.opt (-param=max-store-chains-to-track=): New param.
+	(-param=max-stores-to-track=): Likewise.
+	* doc/invoke.texi (max-store-chains-to-track): Document.
+	(max-stores-to-track): Likewise.
+	* gimple-ssa-store-merging.c (pass_store_merging::m_n_chains):
+	New.
+	(pass_store_merging::m_n_stores): Likewise.
+	(pass_store_merging::terminate_and_process_chain): Update
+	m_n_stores and m_n_chains.
+	(pass_store_merging::process_store): Likewise.   Terminate
+	oldest chains if the number of stores or chains get too large.
+	(imm_store_chain_info::terminate_and_process_chain): Dump
+	chain length.
+
 2021-02-11  Eric Botcazou  <ebotcazou@adacore.com>
 
 	* config/i386/winnt.c (i386_pe_seh_unwind_emit): When switching to
diff --git a/gcc/DATESTAMP b/gcc/DATESTAMP
index 027c5a0d149..fb871023722 100644
--- a/gcc/DATESTAMP
+++ b/gcc/DATESTAMP
@@ -1 +1 @@
-20210212
+20210213
diff --git a/gcc/ada/ChangeLog b/gcc/ada/ChangeLog
index 43973550502..52faefaa2ae 100644
--- a/gcc/ada/ChangeLog
+++ b/gcc/ada/ChangeLog
@@ -1,3 +1,7 @@
+2021-02-12  Arnaud Charlet  <charlet@adacore.com>
+
+	* repinfo.ads, repinfo.adb (*SO_Ref*): Restore.
+
 2021-02-03  Eric Botcazou  <ebotcazou@adacore.com>
 
 	* gcc-interface/decl.c (components_to_record): If the first component
diff --git a/gcc/analyzer/ChangeLog b/gcc/analyzer/ChangeLog
index 4cc5097ab1d..59f6d921055 100644
--- a/gcc/analyzer/ChangeLog
+++ b/gcc/analyzer/ChangeLog
@@ -1,3 +1,30 @@
+2021-02-12  David Malcolm  <dmalcolm@redhat.com>
+
+	PR analyzer/98969
+	* engine.cc (readability): Add names for the various arbitrary
+	values.  Handle NOP_EXPR and INTEGER_CST.
+	(readability_comparator): Combine the readability tests for
+	tree and stack depth, rather than performing them sequentially.
+	(impl_region_model_context::on_state_leak): Strip off top-level
+	casts.
+	* region-model.cc (region_model::get_representative_path_var): Add
+	type-checking, moving the bulk of the implementation to...
+	(region_model::get_representative_path_var_1): ...here.  Respect
+	types in casts by recursing and re-adding the cast, rather than
+	merely stripping them off.  Use the correct type when handling
+	region_svalue.
+	(region_model::get_representative_tree): Strip off any top-level
+	cast.
+	(region_model::get_representative_path_var): Add type-checking,
+	moving the bulk of the implementation to...
+	(region_model::get_representative_path_var_1): ...here.
+	* region-model.h (region_model::get_representative_path_var_1):
+	New decl
+	(region_model::get_representative_path_var_1): New decl.
+	* store.cc (append_pathvar_with_type): New.
+	(binding_cluster::get_representative_path_vars): Cast path_vars
+	to the correct type when adding them to *OUT_PVS.
+
 2021-02-09  David Malcolm  <dmalcolm@redhat.com>
 
 	PR analyzer/98575
diff --git a/gcc/c-family/ChangeLog b/gcc/c-family/ChangeLog
index dfddd04aca9..1d580d9041c 100644
--- a/gcc/c-family/ChangeLog
+++ b/gcc/c-family/ChangeLog
@@ -1,3 +1,9 @@
+2021-02-12  Martin Sebor  <msebor@redhat.com>
+
+	PR c/99055
+	* c-warn.c (warn_parm_array_mismatch): Free strings returned from
+	print_generic_expr_to_str.
+
 2021-02-10  Richard Biener  <rguenther@suse.de>
 
 	* c-common.c (parse_optimize_options): Free decoded_options.
diff --git a/gcc/cp/ChangeLog b/gcc/cp/ChangeLog
index 46cce66c411..d5997a68fce 100644
--- a/gcc/cp/ChangeLog
+++ b/gcc/cp/ChangeLog
@@ -1,3 +1,66 @@
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	* module.cc (module_state::write_cluster): Check bindings for
+	imported using-decls.
+
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	PR c++/99040
+	* module.cc (trees_in::decl_value): Call add_module_namespace_decl
+	for new namespace-scope entities.
+	(module_state::read_cluster): Don't call add_module_decl here.
+	* name-lookup.h (add_module_decl): Rename to ...
+	(add_module_namespace_decl): ... this.
+	* name-lookup.c (newbinding_bookkeeping): Move into ...
+	(do_pushdecl): ... here.  Its only remaining caller.
+	(add_module_decl): Rename to ...
+	(add_module_namespace_decl): ... here.  Add checking-assert for
+	circularity. Don't call newbinding_bookkeeping, just extern_c
+	checking and incomplete var checking.
+
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	PR c++/99039
+	PR c++/99040
+	* cp-tree.h (CPTI_GLOBAL_TYPE): Delete.
+	(global_type_node): Delete.
+	(IDENTIFIER_TYPE_VALUE): Delete.
+	(IDENTIFIER_HAS_TYPE_VALUE): Delete.
+	(get_type_value): Delete.
+	* name-lookup.h (identifier_type_value): Delete.
+	* name-lookup.c (check_module_override): Don't
+	SET_IDENTIFIER_TYPE_VALUE here.
+	(do_pushdecl): Nor here.
+	(identifier_type_value_1, identifier_type_value): Delete.
+	(set_identifier_type_value_with_scope): Only
+	SET_IDENTIFIER_TYPE_VALUE for local and class scopes.
+	(pushdecl_nanmespace_level): Remove shadow stack nadgering.
+	(do_pushtag): Use REAL_IDENTIFIER_TYPE_VALUE.
+	* call.c (check_dtor_name): Use lookup_name.
+	* decl.c (cxx_init_decl_processing): Drop global_type_node.
+	* decl2.c (cplus_decl_attributes): Don't SET_IDENTIFIER_TYPE_VALUE
+	here.
+	* init.c (get_type_value): Delete.
+	* pt.c (instantiate_class_template_1): Don't call pushtag or
+	SET_IDENTIFIER_TYPE_VALUE here.
+	(tsubst): Assert never an identifier.
+	(dependent_type_p): Drop global_type_node assert.
+	* typeck.c (error_args_num): Don't use IDENTIFIER_HAS_TYPE_VALUE
+	to determine ctorness.
+
+2021-02-12  Jakub Jelinek  <jakub@redhat.com>
+
+	PR c++/97742
+	* parser.c (cp_parser_requirement_seq): Stop iterating after reaching
+	CPP_EOF.
+
+2021-02-12  Jason Merrill  <jason@redhat.com>
+
+	PR c++/97246
+	PR c++/94546
+	* pt.c (extract_fnparm_pack): Check DECL_PACK_P here.
+	(register_parameter_specializations): Not here.
+
 2021-02-11  Marek Polacek  <polacek@redhat.com>
 
 	PR c++/95888
diff --git a/gcc/fortran/ChangeLog b/gcc/fortran/ChangeLog
index 275edc0947d..9a34dd60121 100644
--- a/gcc/fortran/ChangeLog
+++ b/gcc/fortran/ChangeLog
@@ -1,3 +1,9 @@
+2021-02-12  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/99043
+	* trans-expr.c (gfc_conv_procedure_call): Don't reset
+	rank of assumed-rank array.
+
 2021-02-11  Paul Thomas  <pault@gcc.gnu.org>
 
 	PR fortran/98897
diff --git a/gcc/testsuite/ChangeLog b/gcc/testsuite/ChangeLog
index 288ea1dabcb..f3630486104 100644
--- a/gcc/testsuite/ChangeLog
+++ b/gcc/testsuite/ChangeLog
@@ -1,3 +1,62 @@
+2021-02-12  Jakub Jelinek  <jakub@redhat.com>
+
+	* gcc.dg/rtl/aarch64/multi-subreg-1.c: Add dg-do compile directive
+	and restrict the test to aarch64-*-* target only.
+
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	* g++.dg/modules/pr99039_a.C: New.
+	* g++.dg/modules/pr99039_b.C: New.
+
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	PR c++/99040
+	* g++.dg/modules/pr99040_a.C: New.
+	* g++.dg/modules/pr99040_b.C: New.
+	* g++.dg/modules/pr99040_c.C: New.
+	* g++.dg/modules/pr99040_d.C: New.
+
+2021-02-12  Nathan Sidwell  <nathan@acm.org>
+
+	PR c++/99039
+	PR c++/99040
+	* g++.dg/lookup/pr99039.C: New.
+
+2021-02-12  Steve Kargl  <sgk@troutmask.apl.washington.edu>
+
+	PR libfortran/95647
+	* gfortran.dg/ieee/ieee_12.f90: New test.
+
+2021-02-12  Richard Sandiford  <richard.sandiford@arm.com>
+
+	* gcc.dg/rtl/aarch64/multi-subreg-1.c: New test.
+
+2021-02-12  Christophe Lyon  <christophe.lyon@linaro.org>
+
+	PR target/98931
+	* gcc.target/arm/pr98931.c: Add -mthumb
+
+2021-02-12  Tobias Burnus  <tobias@codesourcery.com>
+
+	PR fortran/99043
+	* gfortran.dg/assumed_rank_20.f90: New test.
+
+2021-02-12  Jakub Jelinek  <jakub@redhat.com>
+
+	PR c++/97742
+	* g++.dg/cpp2a/concepts-requires24.C: New test.
+
+2021-02-12  Jason Merrill  <jason@redhat.com>
+
+	PR c++/97246
+	* g++.dg/cpp2a/lambda-generic-variadic21.C: New test.
+
+2021-02-12  David Malcolm  <dmalcolm@redhat.com>
+
+	PR analyzer/98969
+	* g++.dg/analyzer/pr99064.C: New test.
+	* gcc.dg/analyzer/pr98969.c: New test.
+
 2021-02-11  Marek Polacek  <polacek@redhat.com>
 
 	PR c++/95888
diff --git a/libbacktrace/ChangeLog b/libbacktrace/ChangeLog
index d12f6576062..6b072d1c412 100644
--- a/libbacktrace/ChangeLog
+++ b/libbacktrace/ChangeLog
@@ -1,3 +1,9 @@
+2021-02-12  Ian Lance Taylor  <iant@golang.org>
+
+	* configure.ac: Check for objcopy --add-gnu-debuglink by using
+	objcopy --help.
+	* configure: Regenerate
+
 2021-01-18  Ian Lance Taylor  <iant@golang.org>
 
 	* Makefile.am (%_dwz): If dwz fails, use uncompressed debug info.
diff --git a/libgfortran/ChangeLog b/libgfortran/ChangeLog
index 36c2296ef19..114518f75ef 100644
--- a/libgfortran/ChangeLog
+++ b/libgfortran/ChangeLog
@@ -1,3 +1,9 @@
+2021-02-12  Steve Kargl  <sgk@troutmask.apl.washington.edu>
+
+	PR libfortran/95647
+	* ieee/ieee_arithmetic.F90: Flip interfaces of operators .eq. to
+	== and .ne. to /= .
+
 2021-02-11  Jerry DeLisle  <jvdelisle@gcc.gnu.org>
 
 	PR libfortran/98825
diff --git a/libstdc++-v3/ChangeLog b/libstdc++-v3/ChangeLog
index 993f8affd3e..a8938d130bc 100644
--- a/libstdc++-v3/ChangeLog
+++ b/libstdc++-v3/ChangeLog
@@ -1,3 +1,94 @@
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	PR libstdc++/88881
+	* src/c++17/fs_ops.cc (fs::symlink_status): Re-enable workaround.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* doc/xml/manual/status_cxx2014.xml: Document implementation
+	specific properties of std::experimental::filesystem::rename.
+	* doc/xml/manual/status_cxx2017.xml: Document implementation
+	specific properties of std::filesystem::rename.
+	* doc/html/*: Regenerate.
+	* src/c++17/fs_ops.cc (fs::rename): Implement correct behaviour
+	for directories on Windows.
+	* src/filesystem/ops-common.h (__gnu_posix::rename): Use
+	MoveFileExW on Windows.
+	* testsuite/27_io/filesystem/operations/rename.cc: New test.
+	* testsuite/experimental/filesystem/operations/rename.cc: New test.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* testsuite/util/testsuite_fs.h (nonexistent_path): Add
+	random number to the path.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/experimental/internet (address_v6::to_string): Include
+	scope ID in string.
+	* testsuite/experimental/net/internet/address/v6/members.cc:
+	Test to_string() results.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/experimental/internet (address_v6::any): Avoid using
+	memcpy in constexpr function.
+	(address_v6::loopback): Likewise.
+	(make_address_v6): Fix missing return statements on error paths.
+	* include/experimental/io_context: Avoid -Wdangling-else
+	warning.
+	* testsuite/experimental/net/internet/address/v4/members.cc:
+	Remove unused variables.
+	* testsuite/experimental/net/internet/address/v6/members.cc:
+	New test.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/bits/shared_ptr_base.h (__shared_ptr::_M_get_deleter):
+	Add unused attribute to parameter.
+	* src/c++11/shared_ptr.cc (_Sp_make_shared_tag::_S_eq):
+	Likewise.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* testsuite/27_io/basic_ostream/emit/1.cc: Expect test to fail
+	if -fno-rtti is used.
+	* testsuite/30_threads/async/forced_unwind.cc: Expect test
+	to abort if -fno-rtti is used.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* testsuite/util/testsuite_allocator.h (memory_resource):
+	Remove requirement for RTTI and exceptions to be enabled.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* testsuite/27_io/basic_istringstream/rdbuf/char/2832.cc: Use
+	static_cast when RTTI is disabled.
+	* testsuite/27_io/basic_istringstream/rdbuf/wchar_t/2832.cc:
+	Likewise.
+	* testsuite/27_io/basic_ostringstream/rdbuf/char/2832.cc:
+	Likewise.
+	* testsuite/27_io/basic_ostringstream/rdbuf/wchar_t/2832.cc:
+	Likewise.
+	* testsuite/27_io/basic_stringstream/str/char/2.cc:
+	Likewise.
+	* testsuite/27_io/basic_stringstream/str/wchar_t/2.cc:
+	Likewise.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/std/ostream (__syncbuf_base::_S_get): Mark parameter
+	as unused and only use dynamic_cast when RTTI is enabled.
+
+2021-02-12  Jonathan Wakely  <jwakely@redhat.com>
+
+	PR libstdc++/99077
+	* src/c++11/cxx11-ios_failure.cc (__ios_failure(const char*, int)):
+	Change int parameter to error_code, to match std::ios_failure.
+	(__throw_ios_failure(const char*, int)): Construct error_code
+	from int parameter.
+
 2021-02-11  Jonathan Wakely  <jwakely@redhat.com>
 
 	* libsupc++/eh_ptr.cc (_GLIBCXX_EH_PTR_RELOPS_COMPAT): Define


More information about the Gcc-cvs mailing list