[gcc/devel/c++-coroutines] (40 commits) Merge master r12-6003.
Iain D Sandoe
iains@gcc.gnu.org
Thu Dec 16 00:02:15 GMT 2021
The branch 'devel/c++-coroutines' was updated to point to:
9578717495c... Merge master r12-6003.
It previously pointed to:
d5c702be6db... Merge master r12-5964.
Diff:
Summary of changes (added commits):
-----------------------------------
9578717... Merge master r12-6003.
fd43568... d: Merge upstream dmd 93108bb9e, druntime 6364e010, phobos (*)
639ece7... Add new test [PR78969]. (*)
3e714cc... configure: Account CXXFLAGS in gcc-plugin.m4. (*)
308d688... nvptx: Add -misa=sm_75 and -misa=sm_80 (*)
eede249... [nvptx] Add -mptx=7.0 (*)
73c3dac... aarch64: Don't classify vector pairs as short vectors [PR10 (*)
7527dde... c++: Fix warning word splitting [PR103713] (*)
d5c9653... middle-end: REE should always check all vector usages, even (*)
6bf5d91... testsuite: Fix up cpp23/auto-fncast11.C testcase [PR103408] (*)
e75a0a0... dwarf2cfi: Improve cfa_reg comparisons [PR103619] (*)
127c717... i386: Fix emissing of __builtin_cpu_supports. (*)
c0e3445... openmp: Avoid calling operand_equal_p on OMP_CLAUSEs [PR103 (*)
a5b4ebc... libstdc++: Poor man's case insensitive comparisons in time_ (*)
8f9fea4... Add combine splitter to transform vashr/vlshr/vashl_optab t (*)
575ad77... Generate XXSPLTIDP for scalars on power10. (*)
8d443ac... Generate XXSPLTIDP for vectors on power10. (*)
d730aa8... Generate XXSPLTIW on power10. (*)
8ccd8b1... Add LXVKQ support. (*)
c6756b3... Add new constant data structure. (*)
71cc9b8... [PR100518] store by mult pieces: keep addr in Pmode (*)
c95a9f1... [PR100843] store by mult pieces: punt on max_len < min_len (*)
9c6586b... Daily bump. (*)
a2a0c91... Fix ICE. [PR103682] (*)
9a4b451... libstdc++: Support old and new T_FMT for en_HK locale [PR10 (*)
85a438f... [PATCH] stddef.h: add support for musl typedef macro guards (*)
a888259... regrename: Skip renaming if instruction is noop move. (*)
7ce3c23... libstdc++: Fix handling of invalid ranges in std::regex [PR (*)
fda2872... libstdc++: Simplify typedefs by using __UINTPTR_TYPE__ (*)
63bb98e... libstdc++: Simplify definition of std::regex_constants vari (*)
926d649... rs6000: Rename arrays to remove temporary _x suffix (*)
d9421a8... rs6000: Rename functions with "new" in their names (*)
9e855d2... rs6000: Remove rs6000-builtin.def and associated data and f (*)
9791218... rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.de (*)
84c5516... rs6000: Remove altivec_overloaded_builtins array and initia (*)
15c02ab... rs6000: Do not allow combining of multiple assemble quads [ (*)
ca39102... Fortran: prevent NULL pointer dereference in check of passe (*)
e866e1c... Fortran: prevent NULL pointer dereferences checking do-loop (*)
7a54d3d... i386: Implement VxHF vector set/insert/extract with lower A (*)
2cf62ef... rs6000: Remove new_builtins_are_live and dead code it was g (*)
(*) This commit already exists in another branch.
Because the reference `refs/heads/devel/c++-coroutines' matches
your hooks.email-new-commits-only configuration,
no separate email is sent for this commit.
More information about the Gcc-cvs
mailing list