[gcc r11-3215] rs6000: Fix misnamed built-in
William Schmidt
wschmidt@gcc.gnu.org
Wed Sep 16 01:34:54 GMT 2020
https://gcc.gnu.org/g:3f3f28de3f62ce6d3b1454d54c4da7569a60e2c6
commit r11-3215-g3f3f28de3f62ce6d3b1454d54c4da7569a60e2c6
Author: Bill Schmidt <wschmidt@linux.ibm.com>
Date: Tue Sep 15 20:34:22 2020 -0500
rs6000: Fix misnamed built-in
The description in rs6000-builtin.def provides for a builtin named
__builtin_altivec_xst_len_r. However, it is hand-defined in
altivec_init_builtins as __builtin_xst_len_r, against the usual naming
practice. Fix that.
2020-09-15 Bill Schmidt <wschmidt@linux.ibm.com>
gcc/
* config/rs6000/rs6000-call.c (altivec_init_builtins): Fix name
of __builtin_altivec_xst_len_r.
Diff:
---
gcc/config/rs6000/rs6000-call.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gcc/config/rs6000/rs6000-call.c b/gcc/config/rs6000/rs6000-call.c
index 77c7a1149fb..a8b520834c7 100644
--- a/gcc/config/rs6000/rs6000-call.c
+++ b/gcc/config/rs6000/rs6000-call.c
@@ -13490,7 +13490,7 @@ altivec_init_builtins (void)
{
def_builtin ("__builtin_altivec_stxvl", void_ftype_v16qi_pvoid_long,
P9V_BUILTIN_STXVL);
- def_builtin ("__builtin_xst_len_r", void_ftype_v16qi_pvoid_long,
+ def_builtin ("__builtin_altivec_xst_len_r", void_ftype_v16qi_pvoid_long,
P9V_BUILTIN_XST_LEN_R);
}
More information about the Gcc-cvs
mailing list