[gcc(refs/users/rguenth/heads/slp-reorg)] tree-optimization/94266 - fix object type extraction heuristics

Richard Biener rguenth@gcc.gnu.org
Mon Mar 23 15:57:04 GMT 2020


https://gcc.gnu.org/g:8fefa21fcf67f30c467eb3cb73d09cb96d0ea6a8

commit 8fefa21fcf67f30c467eb3cb73d09cb96d0ea6a8
Author: Richard Biener <rguenther@suse.de>
Date:   Fri Mar 20 10:52:02 2020 +0100

    tree-optimization/94266 - fix object type extraction heuristics
    
    This fixes the heuristic deriving an actual object type from a
    MEM_REFs pointer operand to use the more sensible type of an
    actual object instead of the pointed to type.
    
    2020-03-20  Richard Biener  <rguenther@suse.de>
    
            PR tree-optimization/94266
            * gimple-ssa-sprintf.c (get_origin_and_offset): Use the
            type of the underlying object to adjust for the containing
            field if available.

Diff:
---
 gcc/ChangeLog            | 7 +++++++
 gcc/gimple-ssa-sprintf.c | 4 +++-
 2 files changed, 10 insertions(+), 1 deletion(-)

diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index ded73b3164a..563be357329 100644
--- a/gcc/ChangeLog
+++ b/gcc/ChangeLog
@@ -1,3 +1,10 @@
+2020-03-20  Richard Biener  <rguenther@suse.de>
+
+	PR tree-optimization/94266
+	* gimple-ssa-sprintf.c (get_origin_and_offset): Use the
+	type of the underlying object to adjust for the containing
+	field if available.
+
 2020-03-20  Andre Vieira  <andre.simoesdiasvieira@arm.com>
 
 	* config/arm/unspecs.md (UNSPEC_GET_FPSCR): Rename this to ...
diff --git a/gcc/gimple-ssa-sprintf.c b/gcc/gimple-ssa-sprintf.c
index 13640e0fd36..1879686ce0a 100644
--- a/gcc/gimple-ssa-sprintf.c
+++ b/gcc/gimple-ssa-sprintf.c
@@ -2331,7 +2331,9 @@ get_origin_and_offset (tree x, HOST_WIDE_INT *fldoff, HOST_WIDE_INT *off)
 
       if (off)
 	{
-	  tree xtype = TREE_TYPE (TREE_TYPE (x));
+	  tree xtype
+	    = (TREE_CODE (x) == ADDR_EXPR
+	       ? TREE_TYPE (TREE_OPERAND (x, 0)) : TREE_TYPE (TREE_TYPE (x)));
 
 	  /* The byte offset of the most basic struct member the byte
 	     offset *OFF corresponds to, or for a (multidimensional)


More information about the Gcc-cvs mailing list