r278464 - in /branches/c++-coroutines: ChangeLo...

iains@gcc.gnu.org iains@gcc.gnu.org
Tue Nov 19 20:09:00 GMT 2019


Author: iains
Date: Tue Nov 19 20:09:30 2019
New Revision: 278464

URL: https://gcc.gnu.org/viewcvs?rev=278464&root=gcc&view=rev
Log:
c++-coroutines - Address review comments, rename CO_RETRN_EXPR.

Rename CO_RETRN_EXPR to CO_RETURN_EXPR.

2019-11-19  Iain Sandoe  <iain@sandoe.co.uk>

	gcc/cp/ChangeLog:
	* cp-tree.def (CO_RETRN_EXPR): Rename this to ...
	(CO_RETURN_EXPR): ... this.
	* coroutines.cc (finish_co_return_stmt): Rename CO_RETRN_EXPR.
	(coro_maybe_expand_co_return): Likewise.
	* cp-objcp-common.c (cp_common_init_ts): Likewise.
	* pt.c (tsubst_expr): Likewise.
	* tree.c (cp_walk_subtrees): Likewise.


Modified:
    branches/c++-coroutines/ChangeLog.coroutines
    branches/c++-coroutines/gcc/cp/coroutines.cc
    branches/c++-coroutines/gcc/cp/cp-objcp-common.c
    branches/c++-coroutines/gcc/cp/cp-tree.def
    branches/c++-coroutines/gcc/cp/pt.c
    branches/c++-coroutines/gcc/cp/tree.c



More information about the Gcc-cvs mailing list