r271464 - in /trunk/gcc: ChangeLog config/rs600...

amodra@gcc.gnu.org amodra@gcc.gnu.org
Tue May 21 13:36:00 GMT 2019


Author: amodra
Date: Tue May 21 13:36:04 2019
New Revision: 271464

URL: https://gcc.gnu.org/viewcvs?rev=271464&root=gcc&view=rev
Log:
PR90545, gcc.target/powerpc/fold-vec-splats-floatdouble.c fails

I figure a tweak to register_move_cost is better than sprinkling ?s
in instruction operand alternatives.

	PR target/90545
	* config/rs6000/rs6000.c (rs6000_register_move_cost): Increase
	power9 direct move cost.
	* testsuite/gcc.target/powerpc/fold-vec-splats-floatdouble.c:
	Correct comments and rename functions to suit parameters.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/rs6000/rs6000.c
    trunk/gcc/testsuite/gcc.target/powerpc/fold-vec-splats-floatdouble.c



More information about the Gcc-cvs mailing list