r270923 - in /branches/c++-modules: ChangeLog.m...

nathan@gcc.gnu.org nathan@gcc.gnu.org
Mon May 6 21:14:00 GMT 2019


Author: nathan
Date: Mon May  6 21:14:34 2019
New Revision: 270923

URL: https://gcc.gnu.org/viewcvs?rev=270923&root=gcc&view=rev
Log:
	libcpp/
	* include/mkdeps.h: Rename struct mrules to struct mkdeps.
	* mkdeps.c: Likewise.
	* include/cpplib.h (cpp_get_deps): Rename return type..
	* directives.c (cpp_get_deps): Likewise.
	* internal.h (struct cpp_reader): Rename deps field type.
	gcc/cp/
	* cp-tree.h (module_preprocess): Adjust first arg type.
	* module.cc: Rename mrules to mkdeps.
	* lex.c (module_preprocess_token): Rename mrules->mkdeps.
	gcc/c-family/
	* c-opts.c (handle_defered_opts): Rename struct deps to struc mkdeps.

Modified:
    branches/c++-modules/ChangeLog.modules
    branches/c++-modules/gcc/c-family/c-opts.c
    branches/c++-modules/gcc/cp/cp-tree.h
    branches/c++-modules/gcc/cp/lex.c
    branches/c++-modules/gcc/cp/module.cc
    branches/c++-modules/libcpp/directives.c
    branches/c++-modules/libcpp/include/cpplib.h
    branches/c++-modules/libcpp/include/mkdeps.h
    branches/c++-modules/libcpp/internal.h
    branches/c++-modules/libcpp/mkdeps.c



More information about the Gcc-cvs mailing list