r266471 - in /trunk/gcc: ChangeLog config/arm/a...
ktkachov@gcc.gnu.org
ktkachov@gcc.gnu.org
Mon Nov 26 17:50:00 GMT 2018
Author: ktkachov
Date: Mon Nov 26 17:50:03 2018
New Revision: 266471
URL: https://gcc.gnu.org/viewcvs?rev=266471&root=gcc&view=rev
Log:
[arm][1/3] Rename mul64 attr to widen_mul64
The mul64 attribute in types.md causes some confusion as it is used to represent
aarch32 instructions that do widening multiplication to generate 32->64 bit results.
But these types are shared with aarch64, which has native 64-bit multiplication operations.
Those are currently not properly represented, which I will fix in follow-up patches.
For now, this patch renames the mul64 attribute to widen_mul64 to more clearly communicate its meaning.
It mechanically updates all users of that name in config/arm/ (there are no users in config/aarch64).
There is thus no change in behaviour.
* config/arm/types.md (mul64): Rename to...
(widen_mul64): ... This.
* config/arm/arm-generic.md: Rename mul64 to widen_mul64.
* config/arm/cortex-a15.md: Likewise.
* config/arm/cortex-a5.md: Likewise.
* config/arm/cortex-a53.md: Likewise.
* config/arm/cortex-a57.md: Likewise.
* config/arm/cortex-a7.md: Likewise.
* config/arm/cortex-m4.md: Likewise.
* config/arm/exynos-m1.md: Likewise.
* config/arm/marvell-pj4.md: Likewise.
* config/arm/xgene1.md: Likewise.
Modified:
trunk/gcc/ChangeLog
trunk/gcc/config/arm/arm-generic.md
trunk/gcc/config/arm/cortex-a15.md
trunk/gcc/config/arm/cortex-a5.md
trunk/gcc/config/arm/cortex-a53.md
trunk/gcc/config/arm/cortex-a57.md
trunk/gcc/config/arm/cortex-a7.md
trunk/gcc/config/arm/cortex-m4.md
trunk/gcc/config/arm/exynos-m1.md
trunk/gcc/config/arm/marvell-pj4.md
trunk/gcc/config/arm/types.md
trunk/gcc/config/arm/xgene1.md
More information about the Gcc-cvs
mailing list