r263167 - in /trunk/gcc: ChangeLog dump-context...

dmalcolm@gcc.gnu.org dmalcolm@gcc.gnu.org
Tue Jul 31 16:51:00 GMT 2018


Author: dmalcolm
Date: Tue Jul 31 16:51:17 2018
New Revision: 263167

URL: https://gcc.gnu.org/viewcvs?rev=263167&root=gcc&view=rev
Log:
Simplify dump_context by adding a dump_loc member function

This patch removes some duplicated code in dumpfile.c by
reimplementing the various dump_foo_loc calls in terms of dump_foo.

gcc/ChangeLog:
	* dump-context.h (dump_context::dump_loc): New decl.
	* dumpfile.c (dump_context::dump_loc): New member function.
	(dump_context::dump_gimple_stmt_loc): Reimplement using dump_loc
	and dump_gimple_stmt.
	(dump_context::dump_gimple_expr_loc): Likewise, using
	dump_gimple_expr.
	(dump_context::dump_generic_expr_loc): Likewise, using
	dump_generic_expr.
	(dump_context::dump_printf_loc_va): Likewise, using
	dump_printf_va.
	(dump_context::begin_scope): Explicitly using the global function
	"dump_loc", rather than the member function.


Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/dump-context.h
    trunk/gcc/dumpfile.c



More information about the Gcc-cvs mailing list