r267085 - in /branches/gcc-8-branch/gcc: Change...

krebbel@gcc.gnu.org krebbel@gcc.gnu.org
Thu Dec 13 12:03:00 GMT 2018


Author: krebbel
Date: Thu Dec 13 12:03:21 2018
New Revision: 267085

URL: https://gcc.gnu.org/viewcvs?rev=267085&root=gcc&view=rev
Log:
S/390: Use VEC_INEXACT/VEC_NOINEXACT instead of magic numbers.

2018-12-13  Andreas Krebbel  <krebbel@linux.ibm.com>

	Backport from mainline
	2018-12-13  Andreas Krebbel  <krebbel@linux.ibm.com>

	* config/s390/vx-builtins.md ("vec_ctd_s64", "vec_ctd_u64")
	("vec_ctsl", "vec_ctul"): Replace 0 with VEC_NOINEXACT.
	("vec_double_s64", "vec_double_u64"): Replace 4 with VEC_INEXACT.


Modified:
    branches/gcc-8-branch/gcc/ChangeLog
    branches/gcc-8-branch/gcc/config/s390/vx-builtins.md



More information about the Gcc-cvs mailing list