r249444 - in /trunk/gcc: ChangeLog config/aarch...

wilco@gcc.gnu.org wilco@gcc.gnu.org
Wed Jun 21 10:48:00 GMT 2017


Author: wilco
Date: Wed Jun 21 10:48:51 2017
New Revision: 249444

URL: https://gcc.gnu.org/viewcvs?rev=249444&root=gcc&view=rev
Log:
Emit SIMD moves as mov

SIMD moves are currently emitted as ORR.  Change this to use the MOV
pseudo instruction just like integer moves (the ARM-ARM states MOV is the
preferred disassembly), improving readability of -S output.

    gcc/
	* config/aarch64/aarch64.md (movti_aarch64):
	Emit mov rather than orr.
	(movtf_aarch64): Likewise.
	* config/aarch64/aarch64-simd.md (aarch64_simd_mov):
	Emit mov rather than orr.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/aarch64/aarch64-simd.md
    trunk/gcc/config/aarch64/aarch64.md



More information about the Gcc-cvs mailing list