r238818 - in /trunk/gcc: ChangeLog config/aarch...

wilco@gcc.gnu.org wilco@gcc.gnu.org
Thu Jul 28 14:21:00 GMT 2016


Author: wilco
Date: Thu Jul 28 14:21:57 2016
New Revision: 238818

URL: https://gcc.gnu.org/viewcvs?rev=238818&root=gcc&view=rev
Log:
This patch improves the readability of the prolog and epilog code by moving
some code into separate functions.  There is no difference in generated code.

gcc/
	* config/aarch64/aarch64.c (aarch64_pushwb_pair_reg): Rename.
	(aarch64_push_reg): New function to push 1 or 2 registers.
	(aarch64_pop_reg): New function to pop 1 or 2 registers.
	(aarch64_expand_prologue): Use aarch64_push_regs.
	(aarch64_expand_epilogue): Use aarch64_pop_regs.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/aarch64/aarch64.c



More information about the Gcc-cvs mailing list