r214091 - in /trunk/gcc: ChangeLog config/i386/...

kyukhin@gcc.gnu.org kyukhin@gcc.gnu.org
Mon Aug 18 11:02:00 GMT 2014


Author: kyukhin
Date: Mon Aug 18 11:02:31 2014
New Revision: 214091

URL: https://gcc.gnu.org/viewcvs?rev=214091&root=gcc&view=rev
Log:
gcc/
	* config/i386/i386.c: Rename ufloatv8siv8df_mask to ufloatv8siv8df2_mask.
	* config/i386/i386.md
	(define_code_iterator any_float): New.
	(define_code_attr floatsuffix): New.
	* config/i386/sse.md
	(define_mode_iterator VF1_128_256VL): New.
	(define_mode_iterator VF2_512_256VL): New.
	(define_insn "float<si2dfmodelower><mode>2<mask_name>"): Remove unnecessary
	TARGET check.
	(define_insn "ufloatv8siv8df<mask_name>"): Delete.
	(define_insn "<floatsuffix>float<sseintvecmodelower><mode>2<mask_name><round_name>"):
	New.
	(define_mode_attr qq2pssuff): New.
	(define_mode_attr sselongvecmode): New.
	(define_mode_attr sselongvecmodelower): New.
	(define_mode_attr sseintvecmode3): New.
	(define_insn "<floatsuffix>float<sselongvecmodelower><mode>2<mask_name><round_name>"):
	New.
	(define_insn "*<floatsuffix>floatv2div2sf2"): New.
	(define_insn "<floatsuffix>floatv2div2sf2_mask"): New.
	(define_insn "ufloat<si2dfmodelower><mode>2<mask_name>"): New.
	(define_insn "ufloatv2siv2df2<mask_name>"): New.


Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/config/i386/i386.c
    trunk/gcc/config/i386/i386.md
    trunk/gcc/config/i386/sse.md



More information about the Gcc-cvs mailing list