r197669 - in /trunk/gcc: ChangeLog testsuite/Ch...

rguenth@gcc.gnu.org rguenth@gcc.gnu.org
Wed Apr 10 10:40:00 GMT 2013


Author: rguenth
Date: Wed Apr 10 10:40:33 2013
New Revision: 197669

URL: http://gcc.gnu.org/viewcvs?rev=197669&root=gcc&view=rev
Log:
2013-04-10  Richard Biener  <rguenther@suse.de>

	* tree-vectorizer.h (struct _slp_oprnd_info): Remove
	first_const_oprnd field, rename first_def_type to first_op_type.
	* tree-vect-slp.c (vect_create_oprnd_info): Adjust.
	(vect_get_and_check_slp_defs): Always use the type of the
	operand.  Allow mixed vect_external_def, vect_constant_def types.
	(vect_get_constant_vectors): Handle mixed vect_external_def,
	vect_constant_def types.

	* gcc.dg/vect/slp-39.c: New testcase.

Added:
    trunk/gcc/testsuite/gcc.dg/vect/slp-39.c
Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/tree-vect-slp.c
    trunk/gcc/tree-vectorizer.h



More information about the Gcc-cvs mailing list