r176677 - in /branches/x32/gcc: ChangeLog.x32 c...

hjl@gcc.gnu.org hjl@gcc.gnu.org
Sat Jul 23 13:42:00 GMT 2011


Author: hjl
Date: Sat Jul 23 13:42:27 2011
New Revision: 176677

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=176677
Log:
Rename x32_general_operand to si_general_operand.

2011-07-22  H.J. Lu  <hongjiu.lu@intel.com>

	* config/i386/i386.md (general_operand): Replace
	x32_general_operand with si_general_operand.
	(general_szext_operand): Likewise.
	(addsi_1_zext): Likewise.
	(*addsi_2_zext): Likewise.
	(*subsi_1_zext): Likewise.
	(*subsi_2_zext): Likewise.
	(*subsi_3_zext): Likewise.
	(*addsi3_carry_zext): Likewise.
	(*subsi3_carry_zext): Likewise.
	(*andsi_1): Likewise.
	(*andsi_1_zext): Likewise.
	(*andsi_2_zext): Likewise.

	* config/i386/predicates.md (x32_general_operand): Renamed to
	...
	(si_general_operand): This.

Modified:
    branches/x32/gcc/ChangeLog.x32
    branches/x32/gcc/config/i386/i386.md
    branches/x32/gcc/config/i386/predicates.md



More information about the Gcc-cvs mailing list