r168426 - in /branches/melt-branch/gcc: ChangeL...

bstarynk@gcc.gnu.org bstarynk@gcc.gnu.org
Mon Jan 3 14:18:00 GMT 2011


Author: bstarynk
Date: Mon Jan  3 14:18:04 2011
New Revision: 168426

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=168426
Log:

2011-01-03  Basile Starynkevitch  <basile@starynkevitch.net>

	* melt-runtime.h: Rename BPARSTR_* as MELTBPARSTR_* everywhere.
	Remove old backward compatibility hacks.
	Use meltobj_magic & meltobj_class.

	* melt-runtime.c: Likewise.

	* melt/warmelt-outobj.melt (runtypesupport_forwcopy): Add 
	newline generation.


Modified:
    branches/melt-branch/gcc/ChangeLog.MELT
    branches/melt-branch/gcc/melt-runtime.c
    branches/melt-branch/gcc/melt-runtime.h
    branches/melt-branch/gcc/melt/warmelt-outobj.melt



More information about the Gcc-cvs mailing list