r148121 - in /trunk/gcc/ada: ChangeLog gcc-inte...
ebotcazou@gcc.gnu.org
ebotcazou@gcc.gnu.org
Wed Jun 3 10:26:00 GMT 2009
Author: ebotcazou
Date: Wed Jun 3 10:26:20 2009
New Revision: 148121
URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=148121
Log:
* gcc-interface/decl.c (substitution_list): Rename to build_subst_list,
remove unused parameter and simplify.
(gnat_to_gnu_entity) <E_Record_Type>: Do not set TYPE_FIELDS. Factor
common predicate. Rewrite loop for clarity. Use GNU_TYPE directly
as context for all discriminants. Fix formatting nits.
<E_Record_Subtype>: Add cosmetic 'break'. Test Has_Discriminants
before Discriminant_Constraint. Adjust for above renaming. Do not
set GNU_TYPE more than once.
(elaborate_entity): Test Has_Discriminants on the entity and use
Implementation_Base_Type.
(components_to_record): Rename component_list to gnat_component_list.
Retrieve the _Parent field from the list. Fix nits in comments.
Clarify logic in loop. Pass correct arguments to create_field_decl.
Modified:
trunk/gcc/ada/ChangeLog
trunk/gcc/ada/gcc-interface/decl.c
More information about the Gcc-cvs
mailing list