r142123 - in /trunk/gcc: ChangeLog config/mips/...
nemet@gcc.gnu.org
nemet@gcc.gnu.org
Sat Nov 22 17:02:00 GMT 2008
Author: nemet
Date: Sat Nov 22 17:02:14 2008
New Revision: 142123
URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=142123
Log:
* config/mips/mips.md (rdhwr): Rename to rdhwr_synci_step_<mode>.
Use constant 1 as the operand.
* config/mips/mips.c (mips_expand_synci_loop): Make INC Pmode.
Rename gen_rdhwr to gen_rdhwr_synci_step_si or
gen_rdhwr_synci_step_di depending on the size of Pmode.
Modified:
trunk/gcc/ChangeLog
trunk/gcc/config/mips/mips.c
trunk/gcc/config/mips/mips.md
More information about the Gcc-cvs
mailing list