r135592 - in /branches/gcc-4_3-branch/gcc: Chan...

nemet@gcc.gnu.org nemet@gcc.gnu.org
Mon May 19 23:29:00 GMT 2008


Author: nemet
Date: Mon May 19 23:29:29 2008
New Revision: 135592

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=135592
Log:
	PR middle-end/36194
	* combine.c (check_conversion): Rename to check_promoted_subreg. 
	Don't call record_truncated_value from here. 
	(record_truncated_value): Turn it into a for_each_rtx callback. 
	(record_truncated_values): New function. 
	(combine_instructions): Call note_uses with 
	record_truncated_values.  Change name of check_conversion to 
	check_promoted_subreg. 

testsuite/

	* gcc.dg/pr36194.c: New test.

Added:
    branches/gcc-4_3-branch/gcc/testsuite/gcc.dg/pr36194.c
Modified:
    branches/gcc-4_3-branch/gcc/ChangeLog
    branches/gcc-4_3-branch/gcc/combine.c
    branches/gcc-4_3-branch/gcc/testsuite/ChangeLog



More information about the Gcc-cvs mailing list