r126357 - in /trunk/gcc: ChangeLog dwarf2out.c

aoliva@gcc.gnu.org aoliva@gcc.gnu.org
Thu Jul 5 08:30:00 GMT 2007


Author: aoliva
Date: Thu Jul  5 08:30:24 2007
New Revision: 126357

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=126357
Log:
* dwarf2out.c (dw_ranges_by_label_ref): New typedef.
(dw_ranges_struct): Rename block_num to num.  Adjust.
(dw_ranges_by_label_struct): New.
(ranges_by_label, ranges_by_label_allocated,
ranges_by_label_in_use): New variables.
(add_ranges_num): Factored most of the code out of...
(add_ranges): ... this one.  Rewrite in terms of the former.
(add_ranges_by_labels): New.
(output_ranges): Output by-label ranges.
(dwarf2out_finish): Output range for multiple-section
compile_unit.  Output standard DW_AT_low_pc in addition to
unexpected DW_AT_entry_pc.

Modified:
    trunk/gcc/ChangeLog
    trunk/gcc/dwarf2out.c



More information about the Gcc-cvs mailing list