r124034 - in /branches/gcc-4_2-branch/gcc: Chan...
rth@gcc.gnu.org
rth@gcc.gnu.org
Sun Apr 22 01:30:00 GMT 2007
Author: rth
Date: Sun Apr 22 02:30:31 2007
New Revision: 124034
URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=124034
Log:
PR target/28623
* config/alpha/alpha.c (get_unaligned_address): Remove extra_offset
argument; update all callers.
(get_unaligned_offset): New.
* config/alpha/alpha.md (extendqidi2, extendhidi2): Don't use
get_unaligned_address, just pass on the address directly.
(unaligned_extendqidi): Use gen_lowpart instead of open-coding
the subreg in the helper patterns.
(unaligned_extendqidi_le): Use get_unaligned_offset.
(unaligned_extendqidi_be, unaligned_extendhidi_le): Likewise.
(unaligned_extendhidi_be): Likewise.
(unaligned_extendhidi): Tidy.
* config/alpha/alpha-protos.h: Update.
Modified:
branches/gcc-4_2-branch/gcc/ChangeLog
branches/gcc-4_2-branch/gcc/config/alpha/alpha-protos.h
branches/gcc-4_2-branch/gcc/config/alpha/alpha.c
branches/gcc-4_2-branch/gcc/config/alpha/alpha.md
More information about the Gcc-cvs
mailing list