gcc/gcc/ada exp_dist.adb snames.ads snames.adb ...
charlet@gcc.gnu.org
charlet@gcc.gnu.org
Wed Oct 27 13:02:00 GMT 2004
CVSROOT: /cvs/gcc
Module name: gcc
Changes by: charlet@gcc.gnu.org 2004-10-27 13:02:12
Modified files:
gcc/ada : exp_dist.adb snames.ads snames.adb s-parint.ads
s-parint.adb rtsfind.ads
Log message:
2004-10-26 Thomas Quinot <quinot@act-europe.fr>
* exp_dist.adb (Build_General_Calling_Stubs): New formal parameter
RACW_Type, used in the PolyORB version.
Rename RCI_Info to RCI_Locator, for consistency between the PolyORB
version and the GARLIC version.
* snames.ads, snames.adb, s-parint.ads, s-parint.adb:
Rename RCI_Info to RCI_Locator for better consistency between the
GARLIC and PolyORB versions of the distributed systems annex.
(DSA_Implementation_Name): This enumeration lists the possible
implementations of the Partition Communication Subsystem for the
Distributed Systems Annex (DSA). The three available implementations
are the dummy stub implementation (No_DSA), and two versions based on
two different distribution runtime libraries: GARLIC and PolyORB. Both
the GARLIC PCS and the PolyORB PCS are part of the GLADE distribution
technology.
Change the literal GLADE_DSA to GARLIC_DSA to accurately describe
that organization.
* rtsfind.ads: Rename RCI_Info to RCI_Locator for better consistency
between the GARLIC and PolyORB versions of the distributed systems
annex.
Remove RE_Unbounded_Reclaim_Pool since it is unused.
Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/exp_dist.adb.diff?cvsroot=gcc&r1=1.15&r2=1.16
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/snames.ads.diff?cvsroot=gcc&r1=1.31&r2=1.32
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/snames.adb.diff?cvsroot=gcc&r1=1.30&r2=1.31
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/s-parint.ads.diff?cvsroot=gcc&r1=1.8&r2=1.9
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/s-parint.adb.diff?cvsroot=gcc&r1=1.7&r2=1.8
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ada/rtsfind.ads.diff?cvsroot=gcc&r1=1.19&r2=1.20
More information about the Gcc-cvs
mailing list