gcc/gcc ChangeLog ifcvt.c

sayle@gcc.gnu.org sayle@gcc.gnu.org
Sat Dec 18 15:26:00 GMT 2004


CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	sayle@gcc.gnu.org	2004-12-18 15:26:32

Modified files:
	gcc            : ChangeLog ifcvt.c 

Log message:
	* ifcvt.c (total_bb_rtx_cost): Rename function to cheap_bb_rtx_cost_p.
	Take a max_cost argument to avoid scanning large blocks, by returning
	a Boolean instead of a total.  Include the cost of a "fstp %st(0)"
	instruction required to pop dead values off of a register stack.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=2.6874&r2=2.6875
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ifcvt.c.diff?cvsroot=gcc&r1=1.173&r2=1.174



More information about the Gcc-cvs mailing list