gcc/libjava ChangeLog java/text/FieldPosition.java
mkoch@gcc.gnu.org
mkoch@gcc.gnu.org
Thu Nov 27 10:08:00 GMT 2003
CVSROOT: /cvs/gcc
Module name: gcc
Changes by: mkoch@gcc.gnu.org 2003-11-27 10:08:33
Modified files:
libjava : ChangeLog
libjava/java/text: FieldPosition.java
Log message:
2003-11-27 Dalibor Topic <robilad@kaffe.org>
* java/text/FieldPosition.java (equals): Adapted to handle
field_attribute. Added fast-circuit check for comparison to self.
Replaced use of instanceof by getClass to fix symmetry for derived
types.
(toString): Adapted to handle field_attribute. Improved readability.
(hashCode): New method.
2003-11-27 Guilhem Lavaux <guilhem@kaffe.org>
* java/text/FieldPosition.java (field_attribute): New field.
(FieldPosition (Format.Field), FieldPosition(Format.Field, int),
getFieldAttribute): New methods.
Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/ChangeLog.diff?cvsroot=gcc&r1=1.2379&r2=1.2380
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libjava/java/text/FieldPosition.java.diff?cvsroot=gcc&r1=1.5&r2=1.6
More information about the Gcc-cvs
mailing list