[Bug tree-optimization/127170] integer_pow2p supports Complex types; maybe remove it
rguenth at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Tue Sep 1 07:25:24 GMT 2026
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=127170
--- Comment #1 from Richard Biener <rguenth at gcc dot gnu.org> ---
I think it's good for consistency that integer_* predicates support all of
ANY_INTEGRAL_TYPE_P. So I would rather not change that.
Maybe instead rename integer_pow2p to integer_cst_pow2p? For some
reason it doesn't handle VECTOR_CST either.
Or rename all integer_* to [any_]integral_*?
Looking I see quite some inconsistencies :/
More information about the Gcc-bugs
mailing list