[Bug c/125935] [debug] bool type supported in C23, but debug info says _Bool
cvs-commit at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Tue Jun 30 07:25:58 GMT 2026
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=125935
--- Comment #10 from GCC Commits <cvs-commit at gcc dot gnu.org> ---
The master branch has been updated by Jakub Jelinek <jakub@gcc.gnu.org>:
https://gcc.gnu.org/g:510c4a8167db0e021aa4dd381e1dd1dae8412054
commit r17-1996-g510c4a8167db0e021aa4dd381e1dd1dae8412054
Author: Jakub Jelinek <jakub@redhat.com>
Date: Tue Jun 30 09:24:56 2026 +0200
c: Use bool rather than _Bool in debug info and diagnostics for C23 and
later [PR125935]
In C23, the primary boolean spelling is bool rather than _Bool, which is
just a backward compatibility thing.
So, we shouldn't spell the type as _Bool in debug info (and in diagnostics)
but as bool.
Obviously, for C17 and earlier it should be _Bool.
The following patch does that.
2026-06-30 Jakub Jelinek <jakub@redhat.com>
PR c/125935
* c-decl.cc (c_init_decl_processing): Use "bool" rather than
"_Bool"
as the name of boolean_type_node for C23+.
* gcc.dg/debug/dwarf2/pr125935-1.c: New test.
* gcc.dg/debug/dwarf2/pr125935-2.c: New test.
* gcc.dg/debug/dwarf2/pr125935-3.c: New test.
* gcc.dg/debug/ctf/ctf-bitfields-3.c: Expect bool rather than
_Bool.
* gcc.dg/Warray-bounds-65.c: Expect bool in diagnostics instead of
_Bool.
* gcc.dg/Wbad-function-cast-1.c: Likewise.
Reviewed-by: Jeffrey Law <jeffrey.law@oss.qualcomm.com>
More information about the Gcc-bugs
mailing list