[Bug libstdc++/24537] Non-uglified names inside namespace __gnu_cxx

redi at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Fri Nov 4 19:20:29 GMT 2022


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=24537

Jonathan Wakely <redi at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |WAITING

--- Comment #8 from Jonathan Wakely <redi at gcc dot gnu.org> ---
I would like to suggest closing this bug. I don't think we should rename
__gnu_cxx::char_traits, it uses a reserved name. I don't think there is
anything wrong with e.g. __debug::vector or __gnu_cxx::char_traits and we
shouldn't pick ugly names to avoid problems for users who abuse
using-directives.

Changing status to WAITING to start the timer, but if I don't hear otherwise
then I'll close it.


More information about the Gcc-bugs mailing list