[Bug sanitizer/105614] mips64: sanitizer_platform_limits_linux.cpp:75:38: error: static assertion failed

xry111 at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Thu Jun 30 03:34:40 GMT 2022


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105614

Xi Ruoyao <xry111 at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |xry111 at gcc dot gnu.org

--- Comment #10 from Xi Ruoyao <xry111 at gcc dot gnu.org> ---
We've not backported MIPS64 libsanitizer support to GCC 11 so it should not be
enabled.  In configure.tgt we have:

  mips*64*-*-linux*)
    # This clause is only here to not match the supported mips*-*-linux*.
    UNSUPPORTED=1

so I'm not sure how libsanitizer is even being built with 11.3.0 for you.  If
you "played" something with the code, don't do that.  Otherwise, the only real
bug is "libsanitizer enabled for MIPS64 with GCC 11.3.0 while it's not
supported".


More information about the Gcc-bugs mailing list