[Bug c++/92271] for consistency, __is_same_as should be named __is_same
mpolacek at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Thu Dec 5 20:07:00 GMT 2019
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=92271
--- Comment #2 from Marek Polacek <mpolacek at gcc dot gnu.org> ---
Author: mpolacek
Date: Thu Dec 5 20:06:46 2019
New Revision: 279018
URL: https://gcc.gnu.org/viewcvs?rev=279018&root=gcc&view=rev
Log:
PR c++/92271 - make __is_same alias for __is_same_as.
Richard Smith proposed adding a synonym for __is_same_as, to accomodate the
convention of exposing std::SOME_TRAIT<A, B>::value as __SOME_TRAIT(A, B).
So add that alias, and also adjust the C++ printer. I didn't bother changing
the RID_ identifier.
* c-common.c: Add __is_same, an alias for __is_same_as.
* cxx-pretty-print.c (pp_cxx_trait_expression) <case CPTK_IS_SAME_AS>:
Print "__is_same".
* g++.dg/ext/is_same.C: New test.
Added:
trunk/gcc/testsuite/g++.dg/ext/is_same.C
Modified:
trunk/gcc/c-family/ChangeLog
trunk/gcc/c-family/c-common.c
trunk/gcc/cp/ChangeLog
trunk/gcc/cp/cxx-pretty-print.c
trunk/gcc/testsuite/ChangeLog
More information about the Gcc-bugs
mailing list