[Bug gcov-profile/87553] [9 regression] g++.dg/tree-prof/inline_mismatch_args.C etc. FAIL

ro at CeBiTec dot Uni-Bielefeld.DE gcc-bugzilla@gcc.gnu.org
Mon Oct 8 15:06:00 GMT 2018


--- Comment #6 from ro at CeBiTec dot Uni-Bielefeld.DE <ro at CeBiTec dot Uni-Bielefeld.DE> ---
> --- Comment #5 from Martin Liška <marxin at gcc dot gnu.org> ---
>> Sorry, I've been doing too many things at once and not been paying close
>> enough attention.  Besides, the g++.log file lacks the "spawn ..." line
>> for executing the binary, so I missed this (obvious) step.
> That's true, but it should only run the executable without arguments.

Indeed: it's easy if you don't forget the step ;-)

>> Whatever, when I run the executable, inline_mismatch_args.gcda *is*
>> generated.  Still, when I run the -fprofile-use step, I get the warnings
>> reported.
> Then it's hard to guess..

I've now checked the .gcda file on Solaris 11 where things work fine:
it's the same size (312 bytes) and both files barely differ:

$ cmp -l inline_mismatch_args.gcda.s10 ~/inline_mismatch_args.gcda.s11
 10   2  64
 11 316   0
 12 333 202

More information about the Gcc-bugs mailing list