[Bug target/56010] Powerpc, -mcpu=native and -mtune=native use the wrong name for target 7450
bergner at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Wed Jan 10 21:44:00 GMT 2018
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=56010
Peter Bergner <bergner at gcc dot gnu.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|UNCONFIRMED |ASSIGNED
Last reconfirmed| |2018-01-10
Assignee|unassigned at gcc dot gnu.org |bergner at gcc dot gnu.org
Ever confirmed|0 |1
--- Comment #5 from Peter Bergner <bergner at gcc dot gnu.org> ---
Going through the kernel cputable.c file and comparing it to rs6000-cpus.def, I
think the name translation should like:
These kernel AT_PLATFORM names can be used as is:
.platform = "powerpc",
.platform = "power3",
.platform = "power4",
.platform = "power5",
.platform = "power5+",
.platform = "power6",
.platform = "power6x",
.platform = "power7",
.platform = "power8",
.platform = "power9",
This kernel AT_PLATFORM name should strip the '+' off:
.platform = "power7+", -> "power7"
These kernel AT_PLATFORM names should strip the 'ppc' prefix off:
.platform = "ppc970", -> "970"
.platform = "ppc601", -> "601"
.platform = "ppc603", -> "603"
.platform = "ppc604", -> "604"
.platform = "ppc750", -> "750"
.platform = "ppc7400", -> "7400"
.platform = "ppc7450", -> "7450"
.platform = "ppc823", -> "823"
.platform = "ppc403", -> "403"
.platform = "ppc8540", -> "8540"
.platform = "ppc8548", -> "8548"
.platform = "ppce5500", -> "e5500"
.platform = "ppce6500", -> "e6500"
These kernel AT_PLATFORM names should strip their prefix and suffix off:
.platform = "ppc440gp", -> "440"
.platform = "ppc-cell-be", -> "cell"
These kernel AT_PLATFORM names should strip the 'ppc' prefix off, as
well as test the AT_HWCAP for PPC_FEATURE_HAS_FPU:
.platform = "ppc405", -> "405" | "405fp"
.platform = "ppc440", -> "440" | "440fp"
This kernel AT_PLATFORM name should strip the 'ppc' prefix off, change
470 to 476 as well as test the AT_HWCAP for PPC_FEATURE_HAS_FPU:
.platform = "ppc470", -> "476" | "476fp"
This kernel AT_PLATFORM name should strip the 'ppc' prefix off, as
well as test the AT_HWCAP for PPC_FEATURE_64::
.platform = "ppce500mc", -> "e500mc" | "e500mc64"
These kernel AT_PLATFORM names do not seem to have an equivalent
rs6000-cpus.def entry, so we probably should just treat them as
unknown/non-existent names:
.platform = "pa6t",
.platform = "ppc5554",
I will take a stab at adding this name translation, which should also fix
PR83743.
I do question though, whether we should test the AT_HWCAP bits or not. Just
because we're on, say a 476fp system, doesn't mean the toolchain and libraries
are compiled with FP support. Thoughts anyone?
More information about the Gcc-bugs
mailing list