[Bug middle-end/63441] incorrect "array subscript is below/above array bounds" diagnostic

msebor at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Thu Nov 16 17:33:00 GMT 2017


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63441

Martin Sebor <msebor at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
      Known to work|                            |5.4.0, 6.4.0, 7.1.0, 8.0
           See Also|                            |https://gcc.gnu.org/bugzill
                   |                            |a/show_bug.cgi?id=63477
         Resolution|---                         |WORKSFORME

--- Comment #3 from Martin Sebor <msebor at gcc dot gnu.org> ---
Just like with pr63477, I cannot reproduce the warning with this test case in
GCC 8.0 anymore (despite what I said in comment #2), or 7-branch, or 6-branch,
or even 5-branch.  Just like in pr63477, bisection also points to r220157 (gcc
5.0.0) as the fix.  So I'll assume that what I saw in comment #2 was some
transient fluke and resolve this as worksforsome (based on comment #1 and #2
saying it would make sense to diagnose this).


More information about the Gcc-bugs mailing list