[Bug bootstrap/82856] --enable-maintainter-mode broken by incompatiblity of gcc's required automake and modern Perl

tkoenig at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Tue Nov 7 08:17:00 GMT 2017


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=82856

Thomas Koenig <tkoenig at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEW
   Last reconfirmed|                            |2017-11-07
            Summary|[8 Regression]              |--enable-maintainter-mode
                   |--enable-maintainter-mode   |broken by incompatiblity of
                   |broken by automake failure  |gcc's required automake and
                   |                            |modern Perl
     Ever confirmed|0                           |1

--- Comment #5 from Thomas Koenig <tkoenig at gcc dot gnu.org> ---
It seems that automake 1.15.1 fixed the issue.

This is not really a regression, it is just relying on an old version
finally started to break things.

So, it seems it is finally time to update all the auto* tools
for gcc. I don't think using a hand-patched version like in
comment #3 is really an option.


More information about the Gcc-bugs mailing list