[Bug other/79792] configuring a nvptx-none build with --program-suffix=-7 results in a misnamed installed binary
doko at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Thu Mar 2 07:37:00 GMT 2017
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79792
--- Comment #1 from Matthias Klose <doko at gcc dot gnu.org> ---
--program-prefix= and --program-suffix= are never passed into the gcc subdir,
but are transformed to a --program-transform-name.
the toplevel (expanded from an autoconf macro) has:
# The aliases save the names the user supplied, while $host etc.
# will get canonicalized.
test -n "$target_alias" &&
test "$program_prefix$program_suffix$program_transform_name" = \
NONENONEs,x,x, &&
program_prefix=${target_alias}-
so the new program_prefix is ignored when --program-suffix= is passed. A work
around is to explicitly use --program-prefix=-<target-alias>.
More information about the Gcc-bugs
mailing list