[Bug target/79883] avr i18n: untranslated "interrupt" or "signal"

gjl at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Wed Jul 12 15:38:00 GMT 2017


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79883

Georg-Johann Lay <gjl at gcc dot gnu.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED
   Target Milestone|---                         |7.2

--- Comment #9 from Georg-Johann Lay <gjl at gcc dot gnu.org> ---
Fixed in 7.2.

The respective parts are quoted now.

The function name is not repeated in the diagnostics as that name preceeds all
the messages like in:

foo.c: In function 'main':
foo.c:3:5: error: ...
...

Only the diagnostic complaining about a missing "__vector" prefix repeats the
function name, but for the other diagnostics (like wrong prototype) the very
name doesn't actually matter.

Also enclosed in WITH_AVRLIBC now because this is naming convention of
AVR-LibC.


More information about the Gcc-bugs mailing list