[Bug tree-optimization/69376] [6 Regression] wrong code at -Os and above on x86_64-linux-gnu

jakub at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Fri Jan 22 14:14:00 GMT 2016


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69376

--- Comment #9 from Jakub Jelinek <jakub at gcc dot gnu.org> ---
(In reply to Bernd Schmidt from comment #8)
> Why not put this bit into range_info_def so as to not have the information
> scattered across two different places? Seems like it would be more robust
> and more readable.

It would, but it would increase the size of it by 64 bits.  As we want to use
these more and more, even for IPA VRP, the memory footprint of the range info
matters.


More information about the Gcc-bugs mailing list