[Bug fortran/78674] New: [cleanup] merge gfc_convert_type_warn and gfc_convert_chartype
janus at gcc dot gnu.org
gcc-bugzilla@gcc.gnu.org
Sun Dec 4 20:42:00 GMT 2016
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78674
Bug ID: 78674
Summary: [cleanup] merge gfc_convert_type_warn and
gfc_convert_chartype
Product: gcc
Version: 7.0
Status: UNCONFIRMED
Severity: normal
Priority: P3
Component: fortran
Assignee: unassigned at gcc dot gnu.org
Reporter: janus at gcc dot gnu.org
Target Milestone: ---
Follow-up to PR78618 ...
The functions gfc_convert_type_warn and gfc_convert_chartype in intrinsic.c
have a lot of code duplication. The latter is almost a subset / special case of
the former.
One should investigate whether it's possible to merge both into one general
function.
More information about the Gcc-bugs
mailing list