[Bug middle-end/65686] [4.9 regression] inconsistent warning maybe-uninitialized: warn about 'unsigned', not warn about 'int'

dimhen at gmail dot com gcc-bugzilla@gcc.gnu.org
Sun Apr 12 20:03:00 GMT 2015


https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65686

Dmitry G. Dyachenko <dimhen at gmail dot com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|incorrect warning           |[4.9 regression]
                   |maybe-uninitialized         |inconsistent warning
                   |                            |maybe-uninitialized: warn
                   |                            |about 'unsigned', not warn
                   |                            |about 'int'

--- Comment #1 from Dmitry G. Dyachenko <dimhen at gmail dot com> ---
gcc version 4.9.3 20150412 (prerelease) [gcc-4_9-branch revision 222021] (GCC)
PASS



More information about the Gcc-bugs mailing list