http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60551 --- Comment #1 from Sergei Trofimovich <slyfox at inbox dot ru> --- Clarification: 'a.cc' should be named as 'a.hh' as it's a header included in many other .cc files.