[Bug c/59963] Wrong column number for warning -Woverflow

mpolacek at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Fri Jan 31 08:14:00 GMT 2014


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=59963

--- Comment #2 from Marek Polacek <mpolacek at gcc dot gnu.org> ---
Author: mpolacek
Date: Fri Jan 31 08:13:50 2014
New Revision: 207335

URL: http://gcc.gnu.org/viewcvs?rev=207335&root=gcc&view=rev
Log:
    PR c/59963
c-family/
    * c-common.c (add_atomic_size_parameter): Pass vNULL to
    build_function_call_vec.
    (resolve_overloaded_builtin): Likewise.
    * c-common.h (build_function_call_vec): Adjust declaration.
cp/
    * typeck.c (build_function_call_vec): Add dummy arg_loc parameter.
c/
    * c-typeck.c (convert_lvalue_to_rvalue): Pass vNULL to
    build_function_call_vec.
    (build_function_call): Likewise.
    (build_atomic_assign): Likewise.
    (build_function_call_vec): Add arg_loc parameter.  Use it.
    (convert_arguments): Likewise.
    (convert_for_assignment): Rename rhs_loc to expr_loc.
    * c-parser.c (c_parser_attributes): Pass NULL to c_parser_expr_list.
    (c_parser_objc_keywordexpr): Likewise.
    (c_parser_postfix_expression_after_primary): Call
    build_function_call_vec with expr_loc rather than op_loc.
    Call c_parser_expr_list to fill arg_loc.  Pass arg_loc to
    build_function_call_vec.
    (c_parser_expr_list): Add locations parameter.  Fill it with locations
    of function arguments.
    * c-decl.c (finish_decl): Pass vNULL to build_function_call_vec.
objc/
    * objc-next-runtime-abi-02.c (build_throw_stmt): Pass vNULL to
    build_function_call_vec.
    (finish_catch): Likewise.
    (next_runtime_abi_02_get_class_reference): Likewise.
    * objc-next-runtime-abi-01.c (build_objc_method_call): Pass vNULL to
    build_function_call_vec.
    (build_throw_stmt): Likewise.
    * objc-gnu-runtime-abi-01.c: (build_objc_method_call): Pass vNULL to
    build_function_call_vec.
    (build_throw_stmt): Likewise.
testsuite/
    * gcc.dg/pr59940.c (g): Adjust dg-warning.
    (y): Adjust dg-error.
    * gcc.dg/cast-function-1.c (bar): Adjust dg-warnings.
    * gcc.dg/pr59963-1.c: New test.
    * gcc.dg/pr59963-2.c: New test.
    * gcc.dg/pr59963-3.c: New test.


Added:
    trunk/gcc/testsuite/gcc.dg/pr59963-1.c
    trunk/gcc/testsuite/gcc.dg/pr59963-2.c
    trunk/gcc/testsuite/gcc.dg/pr59963-3.c
Modified:
    trunk/gcc/c-family/ChangeLog
    trunk/gcc/c-family/c-common.c
    trunk/gcc/c-family/c-common.h
    trunk/gcc/c/ChangeLog
    trunk/gcc/c/c-decl.c
    trunk/gcc/c/c-parser.c
    trunk/gcc/c/c-typeck.c
    trunk/gcc/cp/ChangeLog
    trunk/gcc/cp/typeck.c
    trunk/gcc/objc/ChangeLog
    trunk/gcc/objc/objc-gnu-runtime-abi-01.c
    trunk/gcc/objc/objc-next-runtime-abi-01.c
    trunk/gcc/objc/objc-next-runtime-abi-02.c
    trunk/gcc/testsuite/ChangeLog
    trunk/gcc/testsuite/gcc.dg/cast-function-1.c
    trunk/gcc/testsuite/gcc.dg/pr59940.c



More information about the Gcc-bugs mailing list