[Bug c++/56709] New: Should the passed command parameters result into the same error messages for a configuration test?

Markus.Elfring at web dot de gcc-bugzilla@gcc.gnu.org
Sun Mar 24 13:34:00 GMT 2013


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56709

             Bug #: 56709
           Summary: Should the passed command parameters result into the
                    same error messages for a configuration test?
    Classification: Unclassified
           Product: gcc
           Version: 4.8.0
               URL: http://gcc.gnu.org/ml/gcc-help/2013-02/msg00138.html
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: c++
        AssignedTo: unassigned@gcc.gnu.org
        ReportedBy: Markus.Elfring@web.de
              Host: x86_64-unknown-linux-gnu
            Target: x86_64-unknown-linux-gnu
             Build: x86_64-unknown-linux-gnu


I try to generate the Luyten release of a library combination with the current
compiler again also on my openSUSE Tumbleweed system.

I wonder about the following results here.

elfring@Sonne:~/Projekte/OpalVoip/OPAL/3.10.10> ./configure
--disable-libavcodec
...
checking PTLIB has expat... yes
checking PTLIB has video... no
...

Excerpt from ~/Projekte/OpalVoip/OPAL/3.10.10/config.log:
...
/usr/local/lib64/libpt_s.a(vsdl.o): In function `_GLOBAL__sub_I_vsdl.cxx':
vsdl.cxx:(.text.startup+0x4d): undefined reference to
`PPlugin_PVideoInputDevice_Application_link()'
/usr/local/lib64/libpt_s.a(vfakeio.o): In function
`_GLOBAL__sub_I_vfakeio.cxx':
vfakeio.cxx:(.text.startup+0x4d): undefined reference to
`PPlugin_PVideoInputDevice_Application_link()'
...


elfring@Sonne:~/Projekte/OpalVoip/OPAL/Probe> cat Video2.cpp
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE_URL ""
#define STDC_HEADERS 1
#define OPAL_MAJOR 3
#define OPAL_MINOR 10
#define OPAL_BUILD 10
#define OPAL_VERSION "3.10.10"
#define OPAL_PLUGIN_DIR "/usr/local/lib64/opal-3.10.10"
#define OPAL_PTLIB_SSL 1
#define OPAL_PTLIB_ASN 1
#define OPAL_PTLIB_EXPAT 1

#include <ptbuildopts.h>
#include <ptlib.h>
#include <ptlib/video.h>
int main(void)
{
 PVideoChannel vc;
 return 0;
}
elfring@Sonne:~/Projekte/OpalVoip/OPAL/Probe> LANG=C g++ -o Video2 -Wall
-Wextra -Wstrict-aliasing -Wfloat-equal -Wno-comment -Wno-unused -Winit-self
-Wno-missing-field-initializers -Wreorder -fexceptions -fPIC -DP_64BIT
-DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -I/usr/local/include
-I/usr/include/SDL -L/usr/local/lib64 -lpt_s -lrt -lsasl2 -lldap -llber
-lldap_r -lssl -lcrypto -lexpat -llua -lSDL -lpthread -lodbc -lresolv -ldl
Video2.cpp
/tmp/cc26k0ex.o: In function `main':
Video2.cpp:(.text+0x17): undefined reference to
`PVideoChannel::PVideoChannel()'
Video2.cpp:(.text+0x2b): undefined reference to
`PVideoChannel::~PVideoChannel()'
/tmp/cc26k0ex.o: In function `__static_initialization_and_destruction_0(int,
int)':
Video2.cpp:(.text+0x8c): undefined reference to
`PFactoryLoader::PluginLoaderStartup_link()'
Video2.cpp:(.text+0x97): undefined reference to
`PPlugin_PVideoInputDevice_FakeVideo_link()'
Video2.cpp:(.text+0xa2): undefined reference to
`PPlugin_PVideoInputDevice_Application_link()'
Video2.cpp:(.text+0xad): undefined reference to
`PPlugin_PVideoInputDevice_FFMPEG_link()'
Video2.cpp:(.text+0xb8): undefined reference to
`PPlugin_PVideoInputDevice_YUVFile_link()'
Video2.cpp:(.text+0xc3): undefined reference to
`PPlugin_PVideoOutputDevice_SDL_link()'
collect2: error: ld returned 1 exit status


I find it strange that the reduced command parameter set (deletion of
duplicated options and preprocessor symbols) shows differences in the error
messages.



More information about the Gcc-bugs mailing list