[Bug bootstrap/53675] New: [4.8 Regression] bootstrap fails on netbsd5.1 due to unsupported dwarf4 info

redi at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Thu Jun 14 21:07:00 GMT 2012


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53675

             Bug #: 53675
           Summary: [4.8 Regression] bootstrap fails on netbsd5.1 due to
                    unsupported dwarf4 info
    Classification: Unclassified
           Product: gcc
           Version: 4.8.0
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: bootstrap
        AssignedTo: unassigned@gcc.gnu.org
        ReportedBy: redi@gcc.gnu.org
              Host: x86_64-unknown-netbsd5.1
            Target: x86_64-unknown-netbsd5.1
             Build: x86_64-unknown-netbsd5.1


Created attachment 27621
  --> http://gcc.gnu.org/bugzilla/attachment.cgi?id=27621
build log

Bootstrap fails on gcc70 in the compile farm with linker errors like this:

/usr/bin/ld: Dwarf Error: found dwarf version '4', this reader only handles
version 2 information.
../src/c++11/.libs/libc++11convenience.a(functexcept.o): In function
`_ZZSt9call_onceIMNSt13__future_base11_State_baseEFvRSt8functionIFSt10unique_ptrINS0_12_Result_baseENS4_8_DeleterEEvEERbEJKPS1_St17reference_wrapperIS8_ESF_IbEEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv':
functexcept.cc:(.text._ZZSt9call_onceIMNSt13__future_base11_State_baseEFvRSt8functionIFSt10unique_ptrINS0_12_Result_baseENS4_8_DeleterEEvEERbEIKPS1_St17reference_wrapperIS8_ESF_IbEEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv+0x0):
multiple definition of
`_ZZSt9call_onceIMNSt13__future_base11_State_baseEFvRSt8functionIFSt10unique_ptrINS0_12_Result_baseENS4_8_DeleterEEvEERbEIKPS1_St17reference_wrapperIS8_ESF_IbEEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv'
/usr/bin/ld: Dwarf Error: found dwarf version '4', this reader only handles
version 2 information.
.libs/compatibility-thread-c++0x.o:compatibility-thread-c++0x.cc:(.text._ZZSt9call_onceIMNSt13__future_base11_State_baseEFvRSt8functionIFSt10unique_ptrINS0_12_Result_baseENS4_8_DeleterEEvEERbEIKPS1_St17reference_wrapperIS8_ESF_IbEEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv+0x0):
first defined here
../src/c++11/.libs/libc++11convenience.a(functexcept.o): In function
`_ZZSt9call_onceIMSt6threadFvvEJSt17reference_wrapperIS0_EEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv':
functexcept.cc:(.text._ZZSt9call_onceIMSt6threadFvvEISt17reference_wrapperIS0_EEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv+0x0):
multiple definition of
`_ZZSt9call_onceIMSt6threadFvvEISt17reference_wrapperIS0_EEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv'
.libs/compatibility-thread-c++0x.o:compatibility-thread-c++0x.cc:(.text._ZZSt9call_onceIMSt6threadFvvEISt17reference_wrapperIS0_EEEvRSt9once_flagOT_DpOT0_ENUlvE_4_FUNEv+0x0):
first defined here

Binutils is pretty old:

ld -V
GNU ld version 2.16.1
  Supported emulations:
   elf_x86_64
   elf_i386
   i386nbsd

Configure command is:

/home/jwakely/src/gcc/configure --prefix=/home/jwakely/gcc/4.x
--with-system-zlib --with-gnu-ld --with-gnu-as --with-dwarf2
--enable-languages=c,c++ --disable-libquadmath --disable-libmudflap
--disable-libitm --disable-decimal-float --disable-nls

Note that I specifically requested --with-dwarf2, which makes no difference.



More information about the Gcc-bugs mailing list