[Bug target/35124] Method _alloca is defined different by MSVCRT as by gcc.

dannysmith at users dot sourceforge dot net gcc-bugzilla@gcc.gnu.org
Thu Feb 14 01:43:00 GMT 2008



------- Comment #4 from dannysmith at users dot sourceforge dot net  2008-02-14 01:43 -------
Actually, I see this as unfortunate choice of name for the undocumented
__alloca label rather than as a serious bug. 

__alloca is an internal symbol that should have been named _alloca_probe for
consistency with MSVCT.    

Certainly it is not a regression.  It has been that way since 1996.  The mingw
header malloc.h  does this to get a MSVCRT-consistent alloca:
#ifdef __GNUC__
#define _alloca(x) __builtin_alloca((x))
#endif 


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=35124



More information about the Gcc-bugs mailing list