[Bug libstdc++/29367] pb_ds hash containers vs. _GLIBCXX_DEBUG
bkoz at gcc dot gnu dot org
gcc-bugzilla@gcc.gnu.org
Fri Sep 7 02:26:00 GMT 2007
------- Comment #3 from bkoz at gcc dot gnu dot org 2007-09-07 02:25 -------
Subject: Bug 29367
Author: bkoz
Date: Fri Sep 7 02:25:45 2007
New Revision: 128222
URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=128222
Log:
2007-09-06 Benjamin Kosnik <bkoz@redhat.com>
PR libstdc++/29367
* include/ext/pb_ds/detail/map_debug_base.hpp: From this..
* include/ext/pb_ds/detail/debug_map_base.hpp: ...to this.
Rename map_debug_base to debug_map_base, add std::pair output
extractors, change duplicate map_debug_base typedef in containers
to debug_base. Use m_store_extra_indicator for m_store_hash_indicator.
* include/ext/pb_ds/*: Likewise.
* include/Makefile.am: Same.
* include/Makefile.in: Regenerate.
Modified:
trunk/libstdc++-v3/ChangeLog
--
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29367
More information about the Gcc-bugs
mailing list