[Bug tree-optimization/33680] [4.3 Regression] ICE when compilling elbg.c from ffmpeg (vectorizer)

irar at il dot ibm dot com gcc-bugzilla@gcc.gnu.org
Sun Oct 7 12:31:00 GMT 2007



------- Comment #7 from irar at il dot ibm dot com  2007-10-07 12:31 -------
(In reply to comment #3)

I get:
pr33680.c: In function גfג:
pr33680.c:1: error: expected an SSA_NAME object
pr33680.c:1: error: in statement
D.1618_93 = D.1556 /[ex] 4;
pr33680.c:1: internal compiler error: verify_ssa failed

The problem is that D.1556 is a VAR_DECL and not an SSA_NAME.

This stmt is created while gimplifying data-ref base in
vect_create_addr_base_for_vector_ref(). The expr is
(int[0:D.1553] *) newcentroid.1_22 + (long unsigned int) dim_4(D) * 8

 <pointer_plus_expr 0x2b0e515de8c0
    type <pointer_type 0x2b0e515a34e0
        type <array_type 0x2b0e515a3270 type <integer_type 0x2b0e514975b0 int>
            sizes-gimplified type_1 BLK size <var_decl 0x2b0e515586e0 D.1555>
unit size <var_decl 0x2b0e51558790 D.1556> 
...

D.1618 = D.1556 /[ex] 4 is created, taking D.1556 as the unit size in
gimplify_compound_lval. And later D.1618 is replaced with an SSA_NAME
D.1618_93, since it's a lhs (in gimplify_modify_expr). 

> Vectorizer produces invalid Gimple SSA code:
> 
>   D.1769_169 = D.1599 /[ex] 4;
> 
> D.1599 should be renamed.
> 

Where should it be renamed? In gimplify_smth? 

Thanks,
Ira


-- 

irar at il dot ibm dot com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |irar at il dot ibm dot com


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=33680



More information about the Gcc-bugs mailing list