[Bug other/29049] possible problem: building gcc >= 4.2 on i686 GNU/Linux|SMP (non-64bit) platform fails

WISD00M at GMX dot NET gcc-bugzilla@gcc.gnu.org
Wed Sep 13 03:16:00 GMT 2006



------- Comment #23 from WISD00M at GMX dot NET  2006-09-13 03:16 -------
(In reply to comment #22)
> I only saw this with gcc plus the biarch patch.
what exactly is "this", could you be more specific?
did you see the VERY SAME type of error/warnings while trying to build?

and NO: this is an vanilla/unpatched gcc tarball obtained from a gcc mirror
(md5sum: d2b9fc8e612a003be9d490b78b128ae9  gcc-core-4.2-20060906.tar.bz2)

> I have no problem with building gcc 4.2 on Linux/x86 SMP machines.
what is x86 in your case? i486,i586,i686,i786?
what's your kernel version?

The problem I encountered seems CURRENTLY specific to i686/SMP, at least this
is where it's sort of documented that what I experienced here, happened before
(see: http://www.gatago.com/gnu/gcc/help/24669804.html )

Also, trying a compilation of a fresh source tree using:

export mytarget="i686-pc-linux-gnu" && ./configure --target=$mytarget
--build=$mytarget --host=$mytarget

did result in the same error, at the same point.


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29049



More information about the Gcc-bugs mailing list